Opened 4 years ago

Closed 22 months ago

Last modified 15 months ago

#993 closed Bug (fixed)

Automatic aspect ratio adjustment under EVR CP does not work

Reported by: mrduck Owned by: underground78
Priority: normal Milestone: 1.7.0
Component: General Version: 1.4.2499
Severity: minor Keywords:
Cc: Evaluation:

Description

When using EVR, the aspect ratio changes automatically when the source video changes it's aspect ratio. But when using EVR CP, it does not work. Pausing and then unpausing the video will correct it however. Minor bug but still...

Also with the built in non DXVA MPEG2 decoder, the situation is worse. With EVR you much pause-unpause to correct, and then under EVR CP, it does nothing and you have to specify the aspect ratio manually.

Change History (8)

comment:1 Changed 4 years ago by namaiki

Could you post a sample/test video?

comment:2 Changed 4 years ago by mrduck

Ya here is the sample... http://www.sendspace.com/file/kyy3zq

I used a split/combine tool to make the sample smaller. It should be a good sample although the subtitles are now broken. The audio and video still work. I use MPC built in decoders for everything except for the video which I use Microsoft DTV-DVD video decoder. But the same thing happens with other decoders like cyberlink and is exactly the same after I remux my videos from TS to MKV.

comment:3 Changed 4 years ago by namaiki

I can reproduce the issue, but only when using the Microsoft DTV-DVD video decoder + EVR-CP or EVR Sync. (aspect ratio changed without issue when using MPC-HC's built in decoders)

comment:4 Changed 4 years ago by mrduck

I can't use the built in MPEG2 decoder because the needed DXVA mode is not supported by my card (Radeon 5750). So I have to use an external DXVA decoder which gives better quality because of the advanced deinterlacing and video processing features of the graphics card. Otherwise I would use the built in decoder.

comment:5 Changed 2 years ago by xhmikosr

  • Milestone changed from 1.6.x to next release placeholder

comment:6 Changed 22 months ago by Underground78 <underground78@…

  • Owner set to Underground78 <underground78@…>
  • Resolution set to fixed
  • Status changed from new to closed

In c10d6f17cdf50379297c6e35f7aac3c6124d19c3:

Fix handling of aspect ratio changes when using EVR-CP or Sync Renderer with DXVA.

Fixes #993 #2109 #2955.

comment:7 Changed 22 months ago by underground78

  • Component changed from New to Solved
  • Milestone changed from next release placeholder to next release

Will be in the nightly builds as of revision 7585.

comment:8 Changed 15 months ago by xhmikosr

  • Owner changed from Underground78 <underground78@… to underground78
Note: See TracTickets for help on using tickets.