Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#97 closed Bug (invalid)

[DIVX] V_MPEG/ISO/ASP in mkv causes jerky playback when bframes are used

Reported by: tetsuo55 Owned by: nevcairiel
Priority: normal Milestone:
Component: General Version:
Severity: major Keywords:
Cc: Evaluation:


originally bug 2511481

The internal MPEG4 ASP decoder does not work correctly for MKVs with native
V_MPEG4/ISO/ASP for me. The video is jerky. Tried both Haali's and the
internal splitter. Ffdshow does no exhibit this problem.




it seems that this wasn't a bug in MPC-HC but a bug in MKVMerge.
The sample I posted still exhibits this problems, but that seems to be
because of the incorrect muxing. Samples build with the mkvmerge built
today don't have any more problems so I think it is safe to close this bug
report as I cannot reproduce the error with correctly muxed samples
anymore. ( Although the files in still do not work
correctly - you have to look closely to see the jerkyness).


Here's another sample:


I have to go back on my two previous comments: I can reproduce the bug


  • Windows XP SP3
  • MPC-HC 1.2.1161.0 from
  • using internal mpc video decoder
  • tried both internal and haali's mkv splitter
  • deleted all registry keys associated with MPC
  • Radeon x1950 using latest omega
  • haali's renderer, vmr 7 & 9 renderless and overlay
  • ffdshow 2754 does not exhibit the problem
  • vlc 0.99 also works fine

I've created a new sample:


As a site note:
Mosu (developer of mkvmerge) says he will discontinue VFW ASP mode pretty
soon, now that he has fixed the buggy ASP muxing in his app, so you may
want to increase the priority of this bug.


I just made some tests and it seems that the problem only occurs if
B-Frames are used.

Change History (4)

comment:1 Changed 6 years ago by tetsuo55

  • Component changed from MPC_HC_CODECS to Need Info

Can anyone confirm this problem?

Also can anyone confirm that the bug also occurs in ffplay

comment:2 Changed 6 years ago by tetsuo55

  • Owner set to nevcairiel
  • Status changed from new to assigned

comment:3 Changed 6 years ago by nevcairiel

  • Resolution set to invalid
  • Status changed from assigned to closed

comment:4 Changed 6 years ago by tetsuo55

nevcairiel and i confirm that both on ffdshow and mpc-hc internal decoders both xvid and mkvremux samples look exactly the same as far as jerkyness goes.

Note: See TracTickets for help on using tickets.