Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#80 closed Bug (fixed)

[playlist] Change the behaviour of "Shuffle" so that it also enables "repeat all"

Reported by: tetsuo55 Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: General Version:
Severity: major Keywords:
Cc: Underground78, akapuma, johnjonesz Evaluation: need info

Description

Originally bug 2813338

Playing a playlist with "shuffle" checked whill cause MPCHC to exit or stop
when the last song in the list is played. This will occur even when the
last song in the list is the first song played.

Shuffle should auto-engage the "play forever" option when playlists are
running.

Change History (12)

comment:1 Changed 10 years ago by tetsuo55

Component: MPC_HC_GUINew
Summary: [playlist] At the end of the shuffle list mpc-hc either crashes or exits[playlist] Change the behaviour of "Shuffle" so that it also enables "repeat all"

I suggest we look at the behaviour that foobar2000 has.

comment:2 Changed 9 years ago by namaiki

Cc: Underground78 added

comment:3 Changed 9 years ago by Underground78

Component: NewNeed Info

What behavior do you want :
1) are repetitions allowed ?
2) should we play forever or stop when all items have been played at least once ?

Of course the easiest choice would be to just play forever without any other restriction but I am not against doing something a bit more sophisticated.

comment:4 Changed 8 years ago by Underground78

Cc: akapuma added

From ticket #1772:

Replying to akapuma:

Hello,

I'm opening a directory with vorbis music files with "File" "Open directory". After some time (I have 89 tracks), I see the playlist with the 89 tracks. The tracks are in numerical order.

Now, I klick with the right mouse button on the playlist, and I check "shuffle". Now, the music plays in a random order. But if the last track (number 89) is played, the mpc-hc stops.

The problem is: it is random, when track 89 is played. If track 89 is played at the beginning, I will only hear some tracks.

There are 3 possible solutions:

  1. MPC-HC will stop after playing all 89 tracks, not after playing track number 89.
  1. MPC-HC will never end playback.
  1. User can choice between solution 1 and solution 2 (needs an additional switch "repeat all", also functional without shuffle). Best solution.

Best regards

akapuma

comment:5 Changed 8 years ago by Underground78

Was from ticket #1722 sorry...

comment:6 Changed 8 years ago by Underground78

From ticket #1994:

Replying to hj777:

If I have a 7 song playlist (on random) and the player plays track 2, then track 7, it will pause/stop at the end of track 7 although only 2 out of 7 tracks have been played.

Is there a fix for this?

comment:7 Changed 6 years ago by Underground78

Cc: johnjonesz added
Owner: set to Underground78
Status: evaluatedaccepted

I will fix the shuffle mode.

comment:8 Changed 5 years ago by johnjonesz

Still awaiting fix

comment:9 Changed 5 years ago by johnjonesz

Will this bug ever be fixed? It was reported 5 years ago and still playlist ends on last track when in shuffle mode.

comment:10 Changed 5 years ago by Underground78 <underground78@…

Resolution: fixed
Status: acceptedclosed

In 29bf11:

Playlist: Fix and improve shuffle mode:

  • If the playlist was cleared and then the items readded, pressing next would cause a crash (fixes #3028).
  • The first item to play was always the first one in the playlist (fixes #3128).
  • Playback would stop after playing the last item of the playlist even if not all tracks had been played (fixes #80).
  • Going to the previous file used the playlist order instead of the shuffled order (fixes #4442).
  • No tracks will be repeated unless all tracks have been played at least once (fixes #4616).

comment:11 Changed 5 years ago by Underground78

Milestone: next release

Will be in the nightly builds as of revision 1.7.8.211.

comment:12 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.