Opened 5 years ago

Closed 4 years ago

#665 closed Bug (fixed)

Native Blu-ray PCM audio will not play in MKV container

Reported by: santinosan Owned by:
Priority: normal Milestone:
Component: General Version: nightly, specify
Severity: major Keywords:
Cc: aleksoid, nevcairiel, v0lt Evaluation:

Description

None of the Blu-Ray rips in an MKV container(no change to data other than stripping out unwanted items) with PCM soundtracks, such as CRANK or Ratatouille will play audio in MPC. I have confirmed these same files will play correctly in Mediaportal.

Attachments (1)

mpc_sound_8ch.png (161.8 KB) - added by aleksoid 5 years ago.
Proof of play sound

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by xhmikosr

  • Component changed from New to Reproduced
  • Version changed from 1.3.1249 to SVN, specify

comment:2 Changed 5 years ago by aleksoid

This http://forum.doom9.org/showthread.php?p=1427591#post1427591 sample play fine, test at r2288.
MKVSplitter successfully determines 8ch PCM and file play with sound.

comment:3 Changed 5 years ago by xhmikosr

@Aleksoid: it doesn't work for me too.

comment:4 Changed 5 years ago by aleksoid

This sound stream play without any filters.

Changed 5 years ago by aleksoid

Proof of play sound

comment:5 Changed 5 years ago by nevcairiel

Since its a PCM stream it'll usually not try to use any filter and connect directly to the renderer. However, this will cause issues if the hardware does not support the specific format of the PCM stream. MPC-HC does not have a filter to correct this, but in theory ffdshow with enabled RAW audio should be able to (untested).

comment:6 Changed 5 years ago by santinosan

I finally got it to work consitantly...thanks for the pointers. After getting graphedit to work in Windows 7 I saw that the default renderer was not my sound card. I'm not sure what MPC was trying to connect to but it was not compatible. I simply selected my sound card in the renderer options and it worked like a charm. Simple fix, but without graphedit I couldn't figure out where the stream was running into problems.

comment:7 Changed 5 years ago by xhmikosr

  • Cc nevcairiel added

So is this considered as a bug or bad configuration from the user side?

comment:8 Changed 5 years ago by nevcairiel

Its a bug. Works fine with LAVFSplitter since today.

comment:9 Changed 5 years ago by xhmikosr

  • Cc aleksoid v0lt added

comment:10 Changed 4 years ago by v0lt

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r3271

Note: See TracTickets for help on using tickets.