Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#5829 closed Bug (fixed)

After creating thumbnails the video shows black screen

Reported by: LuanMax Owned by: underground78
Priority: normal Milestone:
Component: General Version: nightly, specify
Severity: normal Keywords: 1.7.10.180
Cc: Evaluation:

Description

Please try the following:

(1) Play a video file
(2) Press "Stop" button
(3) Select "File" > "Save thumbnails"
(4) Press "Save" button to create thumbnails
(5) Press "Play" button

Then the video is playing (I can hear the audio, time counter is working properly) but it's showing a black screen.

All this under Windows 7 x64 with filters currently loaded:

  • Default DirectSound Device
  • Enhanced Video Renderer (custom presenter)
  • Audio Switcher
  • LAV Video Decoder (internal)
  • LAV Audio Decoder (internal)
  • LAV Splitter Source (internal)

Change History (10)

comment:1 Changed 11 months ago by underground78

  • Owner set to underground78
  • Status changed from new to accepted

I think I know why it does this.

comment:2 Changed 11 months ago by underground78

Confirmed, it's fixed. One thing I'm not completely sure thought is whether it should return to stopped mode or to paused mode. With what I've done it returns to paused.

comment:3 Changed 11 months ago by LuanMax

Thanks. If I am not mistaken, the player returns paused to the exact position where you start to save the thumbnails. According to this I would restore the stopped (or paused) mode as well. But of course in the end it's a matter of personal taste.

comment:4 Changed 11 months ago by underground78

I will have a look, it should be too hard to return to stopped state.

comment:5 Changed 11 months ago by LuanMax

Yes, any major effort wouldn't be worth it.

comment:6 Changed 11 months ago by underground78

Sorry, I meant "it should NOT be too hard".

comment:7 follow-up: Changed 11 months ago by underground78

As expected it was hard to fix it this way. The stopped state will be restored.

comment:8 in reply to: ↑ 7 Changed 11 months ago by LuanMax

Replying to underground78:

The stopped state will be restored.

Thanks. :)

comment:9 Changed 11 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In c8362e:

Fix: Creating thumbnails while the video was stopped left the player in an undefined state.

The stopped state is now properly restored after creating the thumbnails.

Fixes #5829.

comment:10 Changed 11 months ago by underground78

Will be in the nightly builds as of version 1.7.10.188.

Note: See TracTickets for help on using tickets.