Opened 14 months ago

Closed 13 months ago

Last modified 3 weeks ago

#5748 closed Bug (fixed)

64-bit systems cannot get to Audio, Subtitle or Video options when streaming with Realtek RTL2838UHIDIR

Reported by: FreakyFwoof Owned by: underground78
Priority: normal Milestone: 1.7.11
Component: General Version: 1.7.10
Severity: normal Keywords: 64-bit, RTL, SDR, Audio, video, Subtitles, Bug, Issue
Cc: Evaluation: diagnosed

Description

Today I installed MPC_HC for the first time. I noticed that when playing .ts files, I could change the audio track using 'Play >Audio' and pick the alternate language track for visually impaired customers. As a blind person myself, this is perfect for me. However, attempting to do this using my Realtek SDR does not work.
It does work on my friend's 32-bit system though, so I'm not sure what I'm doing wrong.

From a completely clean install I did the following:

  1. Options >Capture >set RTL DVB tuner as choice
  1. CTRL+V for DVBTV
  1. Scan for channels
  1. Call up BBC1 London from the channel list
  1. Attempt to go to Play >Audio Track - but the option is disabled

I do know that the channel broadcasts multiple audio streams. Subtitle and video options are also disabled. I would be incredibly grateful if somebody could tell me what I can do to fix this.

Windows 7-64, using Realtek RTL2838UHIDIR DVB/DAB USB SDR Dongle

I have provided no screen-shots because I don't know if I could do so adequately, though if asked, I could get help to do so.

Attachments (3)

mpc-hc-settings.reg (77.8 KB) - added by FreakyFwoof 14 months ago.
MPC_HC Settings
MPC-HC - BBC2 Properties.txt (354 bytes) - added by FreakyFwoof 14 months ago.
I loaded BBC2 which I know is showing a program with Audio Description at the moment, and went to shift f10 properties, then to the final field there called 'Created' and copied that info to a text file.
Screenshot 2016-02-02 21.13.51.png (1.1 MB) - added by FreakyFwoof 14 months ago.
Screenshot of the main MPC-HC Window. Observe the text showing '2/3. Celebrities test whether retirement in India is better than in the UK. The group start to settle into normal life in India and take a 150-mile trip to the Taj Mahal. Also in HD. [AD,S]'

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 months ago by underground78

We should probably double-check that MPC-HC really detected multiple audio tracks when scanning.

I guess the easier way would be that you export MPC-HC's settings. To do this, you need to go to Options > Miscellaneous and then press "Export". After saving the file, you can attach it to this ticket using this direct link.

Changed 14 months ago by FreakyFwoof

MPC_HC Settings

Changed 14 months ago by FreakyFwoof

I loaded BBC2 which I know is showing a program with Audio Description at the moment, and went to shift f10 properties, then to the final field there called 'Created' and copied that info to a text file.

Changed 14 months ago by FreakyFwoof

Screenshot of the main MPC-HC Window. Observe the text showing '2/3. Celebrities test whether retirement in India is better than in the UK. The group start to settle into normal life in India and take a 150-mile trip to the Taj Mahal. Also in HD. [AD,S]'

comment:2 Changed 14 months ago by underground78

  • Component changed from Subtitles to General
  • Evaluation set to diagnosed
  • Status changed from new to evaluated

Ok, that seems to be a regression in version 1.7.10. I will look into it.

comment:3 Changed 14 months ago by underground78

  • Owner set to underground78
  • Status changed from evaluated to accepted

I think I have found the problem.

comment:4 Changed 14 months ago by underground78

Could you please try this test build and report back?

comment:5 Changed 14 months ago by FreakyFwoof

Great, that did work yes. Thank you for your hard work on this matter.
The one thing that does not work are the excelerator keys, however.
A for Audio, S for Subtitles, V for Video etc. Should that work or just not in this test-build? I have to go through the play menu to change those. It's not a big deal by the way, merely an observation.

I've posted a Help >About clipboard report for reference:

MPC-HC (Nightly, 64-bit)


Build information:

Version: 1.7.10.109 (9b1bf05-dirty)
Compiler: MSVC 2015 Update 1
Build date: Feb 3 2016 23:55:13

LAV Filters:

LAV Splitter: 0.67.0.70
LAV Video: 0.67.0.70
LAV Audio: 0.67.0.70
FFmpeg compiler: MinGW-w64 GCC 5.3.0

Operating system:

Name: Windows NT 6.1 (build 7601, Service Pack 1)
Version: 6.1 (64-bit)

Hardware:

CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
GPU: Intel(R) HD Graphics 4000 (driver version: 9.17.10.2932)

comment:6 Changed 13 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In 58c3de:

Fix: Track selection menus did not work when using DVB capture.

Fixes #5748.

comment:7 Changed 13 months ago by underground78

  • Milestone set to next release

Will be in the nightly builds as of version 1.7.10.116.

comment:8 Changed 3 weeks ago by thevbm

  • Milestone changed from next release to 1.7.11

Milestone renamed

Note: See TracTickets for help on using tickets.