Opened 17 months ago

Closed 17 months ago

Last modified 3 weeks ago

#5666 closed Bug (fixed)

Black screen in DVD Title Menu with YADIF deinterlacing

Reported by: gcraistlin Owned by: underground78
Priority: normal Milestone: 1.7.11
Component: Internal Filters Version: 1.7.9
Severity: normal Keywords:
Cc: nevcairiel Evaluation:

Description

  1. Download the test DVD: http://mir.cr/0KVKV7UG
  2. In Options | Internal Filters | Video decoder set:

Hardware Decoder to use = None
[x] Enable YADIF Deinterlacing

(.) 25p/30p (Film)

  1. Open the test DVD, press Alt-T to go to the root menu.

You'll get the black screen.

To be precise, the bug is reproducible on WinXP with either AMD or NVIDIA videocard regardless of "Hardware Decoder to use" option. On Win7/AMD with this option set to "DXVA2 (native)" the bug isn't reproducible; with other values it is.
The bug isn't reproducible on 1.7.7.151 and is reproducible on 1.7.7.157 and any later versions.

Change History (12)

comment:1 Changed 17 months ago by gcraistlin

To be even more precise: you will get no black screen but picture freeze.

comment:2 Changed 17 months ago by underground78

  • Cc nevcairiel added
  • Component changed from General to Internal Filters
  • Owner set to underground78
  • Status changed from new to accepted

@nevcairiel: Seems like a problem on LAV Video Decoder side.

comment:3 Changed 17 months ago by nevcairiel

1.7.7.151 and 1.7.7.157 don't tell me anything.

comment:5 Changed 17 months ago by nevcairiel

Seems fine here with latest LAV. I get the menu image and can select options and whatnot.

comment:6 Changed 17 months ago by underground78

@gcraistlin: Please try stable 1.7.10 and any nightly as of 1.7.10.5.

comment:7 Changed 17 months ago by gcraistlin

Still reproducible on 1.7.10 (WinXP/AMD).

comment:8 Changed 17 months ago by gcraistlin

Can't reproduce the bug in 1.7.10.5.

comment:9 Changed 17 months ago by underground78

Ok, thanks for reporting back. I will document the issue in the changelog for clarity.

comment:10 Changed 17 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In d450c6:

Update the changelog to document another issue fixed by c1bda2f8018826b697a6463536308d3d8cef6c78.

The LAV Filters update fixed black screens in DVD menus sometimes caused by YADIF deinterlacing.

Fixes #5666.

comment:11 Changed 17 months ago by underground78

  • Milestone set to next release

comment:12 Changed 3 weeks ago by thevbm

  • Milestone changed from next release to 1.7.11

Milestone renamed

Note: See TracTickets for help on using tickets.