#5548 closed Bug (fixed)

i sent u a copy of the clip board i upgraded to win10 today and now ur app has quit working. worked great with win 8.1.

Reported by: n0th1ng81 Owned by:
Priority: normal Milestone:
Component: Internal Filters Version: 1.7.9
Severity: normal Keywords: MPC-HC (64-bit)
Cc: underground78 Evaluation:

Description

MPC-HC (64-bit)


Build information:

Version: 1.7.9 (846eff0)
Compiler: MSVC 2013 Update 4
Build date: Jun 1 2015 09:16:50

LAV Filters:

LAV Splitter: 0.65.0.9
LAV Video: 0.65.0.9
LAV Audio: 0.65.0.9
FFmpeg compiler: MinGW-w64 GCC 4.9.2

Operating system:

Name: Windows NT 10.0 (build 10240)
Version: 10.0 (64-bit)

Hardware:

CPU: AMD E-300 APU with Radeon(tm) HD Graphics
GPU: AMD Radeon HD 6310 Graphics (driver version: 8.17.10.1404)

Attachments (23)

Screenshot (1).png (41.0 KB) - added by n0th1ng81 20 months ago.
Screenshot (2).png (55.0 KB) - added by n0th1ng81 20 months ago.
Screenshot (3).png (61.4 KB) - added by n0th1ng81 20 months ago.
Screenshot (4).png (83.2 KB) - added by n0th1ng81 20 months ago.
Screenshot (5).png (31.8 KB) - added by n0th1ng81 20 months ago.
Screenshot (6).png (39.9 KB) - added by n0th1ng81 20 months ago.
7z_content.png (48.6 KB) - added by underground78 20 months ago.
Screenshot (8).png (138.8 KB) - added by n0th1ng81 20 months ago.
Screenshot (9).png (165.4 KB) - added by n0th1ng81 20 months ago.
Screenshot (10).png (38.7 KB) - added by n0th1ng81 20 months ago.
Screenshot (11).png (43.7 KB) - added by n0th1ng81 20 months ago.
Screenshot (12).png (46.7 KB) - added by n0th1ng81 20 months ago.
Screenshot (13).png (556.1 KB) - added by n0th1ng81 20 months ago.
Screenshot (14).png (144.3 KB) - added by n0th1ng81 20 months ago.
Screenshot (15).png (144.3 KB) - added by n0th1ng81 20 months ago.
Screenshot (16).png (1.3 MB) - added by n0th1ng81 20 months ago.
Screenshot (17).png (413.5 KB) - added by n0th1ng81 20 months ago.
Screenshot (18).png (411.7 KB) - added by n0th1ng81 20 months ago.
Screenshot (19).png (424.9 KB) - added by n0th1ng81 20 months ago.
Screenshot (20).png (424.4 KB) - added by n0th1ng81 20 months ago.
i kno the vlc attachment are prob useless but i thought mebe
Screenshot (21).png (77.8 KB) - added by n0th1ng81 20 months ago.
Screenshot (22).png (59.3 KB) - added by n0th1ng81 20 months ago.
Screenshot (23).png (64.7 KB) - added by n0th1ng81 20 months ago.

Change History (67)

comment:1 Changed 20 months ago by n0th1ng81

I will wait for an updated version of ur app, please notify me when a workable update is available. my email address is [retracted by U78: no need to feed the spam bots with your email :)]

Last edited 20 months ago by underground78 (previous) (diff)

comment:2 Changed 20 months ago by underground78

  • Cc underground78 added
  • Evaluation set to need info
  • Status changed from new to evaluated

It should work already. Can you explain what is happening exactly (is there an error message, etc.)?

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

comment:3 Changed 20 months ago by n0th1ng81

theirs no error message, it works up until it starts loading the file to open then it gets stuck in a loop I guess it was a mp4 file should be no issue. when u click on to close out the app it becomes unresponsive. never had issues with operating on windows 8 and 8.1 issue started when I upgraded to windows 10 and the app changed colors. when I ran it in windows 8,1 the player was outlined in black and when I open in win 10 it is outlined in white. I tried trouble shooting compatibility and it was the same. app opens in win 10 and when I go to directory and open file its working until it try's to open the file and the screen on the player goes black. the icon of the file type is loading at the left bottom corner but it never opens up just say opening..... and after that point any thing I click on the app say not responding and I have to manually shut it down with task manager. at this point it may be some setting I have that's causing the app not to work. I'm using vlc player which it works but its a little laggy and I don't like the view options I really enjoyed using mpc hc app. I hope u understand what I'm trying to say I'm not that tech literate. I hope the screen shots will help, the file shown I use to watch on windows 8.1 the files aren't bad I watch on vlc now.

attachments

comment:4 Changed 20 months ago by underground78

Please try to create a dump file manually:

  1. Reproduce the freeze, don't close MPC-HC.
  2. If you're on a 32-bit operating system, open the task manager as usual or if you're on a 64-bit operating system, open the task manager from C:\Windows\SysWOW64\taskmgr.exe.
  3. Locate the mpc-hc.exe (or mpc-hc64.exe) process.
  4. Right click on it and press "Create Dump File" (or something similar).
  5. Compress the created dump file and upload the archive for us (on MediaFire, Google Drive, or any file sharing website you like).

comment:5 Changed 20 months ago by n0th1ng81

ok I'm posting a link but I don't know who or what email to attach the file to so if the link don't work its cause I don't have proper contact info
https://drive.google.com/file/d/0Bxg__yOexKvTN0UxcnUweS1CQ1E/view?usp=sharing
if you are not able to access the dump file I will make the link public cus I don't know how else to do it. never mind any one with the link can view ie you, sorry I'm a little slow at this I don't use the cloud much. I hope this helps and thank you for your troubles.

comment:6 Changed 20 months ago by underground78

I think the issue should be fixed by using the latest beta version. Could you try and report back?

comment:7 follow-up: Changed 20 months ago by n0th1ng81

I tried out beta version nightly build and it don't work, thanks any way for trying. I the nightly builds are dl at ur on risk and unstable so I'm sorry I wasted ur time.

comment:8 Changed 20 months ago by clsid2

A few known causes of problems:

  • Broken graphics driver
  • EVGA PrecisionX
  • F-Secure AV HIPS functionality

comment:9 in reply to: ↑ 7 Changed 20 months ago by underground78

Replying to n0th1ng81:

I tried out beta version nightly build and it don't work, thanks any way for trying. I the nightly builds are dl at ur on risk and unstable so I'm sorry I wasted ur time.

I'm not sure I understand but if it does not work with the nightly it's an unexpected issue and we would like to fix it.

Could you please create and upload a new dump with the nightly build?

comment:11 Changed 20 months ago by underground78

  • Cc nevcairiel added
  • Component changed from General to Internal Filters

@nevcairiel: This seems extremely similar to the deadlock you fixed not so long ago.

comment:12 Changed 20 months ago by nevcairiel

Its something else entirely. I have no idea how this could ever happen, but just in case I pushed a small change to hopefully make it absolutely impossible.

comment:13 Changed 20 months ago by n0th1ng81

ok ive been playing around with setting cause I can use any function until I try to load a file and that's when the app quits working. I remembered when I was making a copy of windows ten that I was looking at spec to be able to up grade and I don't know if this has anything to do or not but thought I would let u know,

•If you have Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate, Windows 8 Pro with Media Center, or Windows 8.1 Pro with Media Center and you install Windows 10, Windows Media Center will be removed. For a limited time (the “eligible period”), on systems upgraded to Windows 10 from one of these older versions of Windows (a “qualified system”), a DVD playback app (“windows DVD player”) will be installed. Note: the Windows DVD Player may not be installed immediately; it will be installed after the first successful Windows Update. The Windows DVD Player will be available for purchase from the Window Store for systems that (i) are qualified systems but the eligible period lapsed; (ii) are non-qualified systems; or (iii) were qualified systems but windows 10 was subsequently clean installed (in this case, Windows Update cannot detect that it was previously a qualified system).

I didn't know if this could be to some effect to cause the app to quit working, still don't understand why I'm able to run vlc player and not mpc hc player. and the way its looking I fall under the clean installed.

comment:14 Changed 20 months ago by n0th1ng81

ok here are some things I managed to do, well I think when I tried to watch a .mvk file on vlc player it did a font cache update. don't know what that is, but I think it may have updated codec to be able to play .mvk file. this was after dl ing divx 10 player and it not working and I finally got the file to play on avc app. but when I went into full screen mode it caused the screen to flash like a cd that skips. so I tried your app some more with no luck. I open the file in vlc player when it was trying to do a font cache update I just closed it out, atleast I thought I did. it finally started playing the .mvk files in the vlc player. so I thought vlc is using a win 7 compatibility so I went back to find older version of mpc hc. I tried mplayerc_homecinema_x86_v1.0.10.0. it worked but when I was playing the file it would break up. I downloaded v1.7.8 and it worked. so I tried 1.7.9 and it worked also. I went back and uninstalled all the older versions and for some reason uninstalled the vlc player, well cause I thought it was fixed. The vlc player asked if I want to delete caches so I did and then I tried the mpc hc and it started to do the same not responding. so I will try to redownload vlc and let it do the font cache update and then play vid on mpc hc and create a dump and see if it will help or not. The best I can come up with is windows 10 has got rid of codec s so that the software wont play any files so you have to buy into their inferior software and rent or buy movies from windows store.

comment:15 Changed 20 months ago by underground78

@n0th1ng81: As nevcairiel said, the problem has been identified and fixed so there is no need to worry.

Here is a test build, could you please try it and report back?

comment:16 Changed 20 months ago by n0th1ng81

It may have been fixed on or end it worked for a min then windows defender destroyed it I'm back to using vlc cus I deleted the license s

comment:17 Changed 20 months ago by underground78

It may have been fixed on or end it worked for a min then windows defender

Well I don't see why it did this but anyway it will be in the next beta version.

I'm back to using vlc cus I deleted the license s

I don't understand what this mean.

comment:18 Changed 20 months ago by n0th1ng81

Oh and all he said was he couldn't believed that that happened he thought he would make it so it never would again then it did. What ever it was.

comment:19 Changed 20 months ago by n0th1ng81

Oh if I was worrying its cus it still don't work but I will wait on the next beta version&thanks for all ur hard work to make computer illiterate ppl like me happy.

comment:20 Changed 20 months ago by n0th1ng81

:-D always with the test data I will try it later when I had sleep

comment:21 Changed 20 months ago by nevcairiel

  • Cc nevcairiel removed

comment:22 Changed 20 months ago by n0th1ng81

Their wasn't even a file for mpc in that trash u sent me. If your done just say look dude I can't fix it and leave it at that instead if sending me a spam dl .

comment:23 Changed 20 months ago by underground78

Well I don't know where you clicked but if you click on the big green button that says "Download (8.06 MB)", you will definitively get a 7z archive with the test build inside... Just see the VirusTotal analysis for yourself if you don't trust me.

Anyway here is another download link from Google Drive this time: https://drive.google.com/file/d/0Bw1YzJ40JdqPSVB6Qk9xdmVOdDA/view?usp=sharing.

comment:24 Changed 20 months ago by n0th1ng81

Yeah I got the 7zip full of trash apps and the only mpc files in it were the dump files I uploaded. So u can quit sending me links and quit worrying about trying to upload me a virus cus u can't fix the prob

Changed 20 months ago by underground78

comment:25 Changed 20 months ago by underground78

Are you trying to piss me off or is it the "computer illiterate" speaking?

Here is the content of the 7z I've sent:
https://trac.mpc-hc.org/raw-attachment/ticket/5548/7z_content.png

You just need to extract the content and run mpc-hc64.exe. If you don't know how to do this, then just be honest and tell me instead of blaming me. I will see if I can find an easier way.

comment:26 Changed 20 months ago by clsid2

Dude, the contents are clean and exactly as in the screenshot above.

comment:27 follow-up: Changed 20 months ago by n0th1ng81

The only prob with the screen shot is the directory

comment:28 in reply to: ↑ 27 Changed 20 months ago by underground78

Replying to n0th1ng81:

The only prob with the screen shot is the directory

I don't see why it's a problem. It contains the filters used by MPC-HC internally. If you check the install folder of MPC-HC you will see that this folder exists there too.

Just extract the exe file and the folder in the same directory, then run the exe file.

comment:29 Changed 20 months ago by n0th1ng81

The dir in the screen shot dir G: I can't access its on or computer upload it

comment:30 Changed 20 months ago by underground78

Well that's my computer so it's normal that the path is different. It depends from where you saved the archive file.

Anyway if that's too complex, just way for the next beta version to be available. It should be easier for you to test it.

comment:31 Changed 20 months ago by n0th1ng81

Look I will get off mobile and check again on my PC u sent me a screen shot of a file on ur comp I believe the file exist but if I don't have a link then how am I suppose to test it for you. But I will go PC and see if I can find a link. Its not too hard its just I really would like ur app to work on my comp but the nightly builds and testing gets old when they don't work.

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

comment:32 Changed 20 months ago by n0th1ng81

ok I don't do 7 zip and if that's what ur colleague was tring to do is get me a 7zip opener on my pc I wont use cus I had trouble with malware using 7zip so I guess I will just have to wait or scrap this altogether.

comment:33 Changed 20 months ago by underground78

I see that you are getting confused by the archive so I've created a full installer for you: https://drive.google.com/file/d/0Bw1YzJ40JdqPZmdZYkRscmhXeUk/view?usp=sharing. Just double-click on it and follow the instructions.

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

comment:35 Changed 20 months ago by underground78

The issue visible in the previous dump file seems to be fixed and I cannot see anything obviously wrong in the new one.

What happens exactly when you start playback? Is MPC-HC freezing just like before?

comment:36 Changed 20 months ago by n0th1ng81

It starts in stop and when you hit play it does nothing no does not respond just black screen like I sent u i n screen shot. If or update was for mp4 it may work the file I was trying to play if u zoom in the bottom left hand corner the icon is .mvk.

comment:37 Changed 20 months ago by underground78

The update was supposed to work for all files. I will try to have a look again tomorrow.

In the meantime, you can try reseting the settings from the "Miscellaneous" option page.

Last edited 20 months ago by underground78 (previous) (diff)

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

i kno the vlc attachment are prob useless but i thought mebe

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

Changed 20 months ago by n0th1ng81

comment:38 Changed 20 months ago by n0th1ng81

and I kno that the mpc shots are probly useless but that's what I get on the last update with a black screen set on stop I tried mp4 and mvk with no difference. just stuck on stop and I have all access to dashboard but no play function just stuck on stop.

comment:39 Changed 20 months ago by n0th1ng81

ok I know your prob annoyed and hate me right now and are like if u like vlc somuch use it but I don't and I want mpc to work cause it don't matter if the encoding is for 689 360 or 720 480 or 1366 699 it don't matter I can size it to fit my screen with ur app in full screen mode, and when I go to play list its in order the way I have it filed in my properties and not the way it was filed in the encoding. I have done my own encoding but it takes so long and so much of my cpu to convert files that Ive left them the way I got em. I'm not tring to copy files on to disk to resell that's not what I'm about I just want to be able to watch my files. I apologize if I come of as paranoid. I just don't trust windows or android or google they are always tring to update to where nothing works any more. they are idiots with more money than brains that don't care about nothing but $$$ signs. I don't care if u get it fixed or not any more its just not worth the embarrassment of me putting my self out there and look in like an ass for your enjoyment any more.

comment:40 Changed 20 months ago by underground78

In the meantime, you can try reseting the settings from the "Miscellaneous" option page.

Have you tried this? Also could you copy-paste here the list of filters from "Play > Filters" menu?

comment:41 Changed 20 months ago by Underground78 <underground78@…

In b81d74:

Updated LAV Filters to 0.65-42-0e577b7 (custom build based on 0.65-38-393df3d.

Important changes:

  • LAV Splitter: Fix some rare deadlocks at startup (ticket #5548).

comment:42 Changed 20 months ago by underground78

The fix for the first issue will be in the nightly builds as of version 1.7.9.138.

comment:43 Changed 20 months ago by n0th1ng81

ok I never got any build to work, I also had problems with windows ten playing online videos. So I dumped windows ten and went back to windows 8. I since haven't had any problems with MPC-HC (64-bit)


Build information:

Version: 1.7.9 (846eff0)
Compiler: MSVC 2013 Update 4
Build date: Jun 1 2015 09:16:50

LAV Filters:

LAV Splitter: 0.65.0.9
LAV Video: 0.65.0.9
LAV Audio: 0.65.0.9
FFmpeg compiler: MinGW-w64 GCC 4.9.2

Operating system:

Name: Windows NT 6.2 (build 9200)
Version: 6.2 (64-bit)

Hardware:

CPU: AMD E-300 APU with Radeon(tm) HD Graphics
GPU: AMD Radeon HD 6310 (driver version: 8.17.10.1140)

In theory windows 10 flash player don't work for online videos. I got maybe a 40% play ratio out of windows 10. Adobe flash may not have any thing to do with how your app operates, but I think the problem lies with in the flash player in windows 10, I may be wrong but that's my opinion.

Thanks again for tring, and like I said running windows 8 and ur app is running flawless.

comment:44 Changed 20 months ago by underground78

  • Evaluation need info deleted
  • Resolution set to fixed
  • Status changed from evaluated to closed

Ok, I'm closing the ticket then but feel free to ask us to reopen if you switch back to Windows 10 again.

Note: See TracTickets for help on using tickets.