Opened 21 months ago

Closed 20 months ago

Last modified 17 months ago

#5515 closed Bug (fixed)

PGS subtitles not displayed

Reported by: Shadorino Owned by: underground78
Priority: high Milestone: 1.7.10
Component: Subtitles Version: 1.7.9
Severity: normal Keywords: PGS subtitles
Cc: Evaluation:

Description

Hello,

I've encountered a series of MKV files with PGS subtitles that don't display. Weird thing is I have other MKVs that I ripped myself that do display the subtitles.

I have a sample here :
http://www.mediafire.com/watch/9c2zfw953tqw3rz/House_Of_Cards__S01E02__sample.mkv

I've tried on my desktop PC, on my laptop and asked one of my cousins to check on his computer, it's the same.

It works fine on VLC.

Change History (10)

comment:1 Changed 21 months ago by Aleksoid1978

Confirm. Possible some bug in internal PGS parser/renderer.

comment:2 Changed 21 months ago by Shadorino

Sorry I accidently made a duplicate of this ticket. If someone could delete the #5516, thanks :)

Last edited 21 months ago by Shadorino (previous) (diff)

comment:3 Changed 21 months ago by kasper93

Closed. I will look at this tonight. Thanks for the sample.

comment:4 Changed 21 months ago by Shadorino

Thanks for closing the duplicate. Keep me posted.

comment:5 Changed 21 months ago by underground78

  • Owner set to underground78
  • Status changed from new to accepted

I've found and fixed the problem.

comment:6 follow-up: Changed 21 months ago by Shadorino

Cool. Will it be in the next nightly build ?

comment:7 in reply to: ↑ 6 Changed 21 months ago by underground78

Replying to Shadorino:

Cool. Will it be in the next nightly build ?

Yes.

comment:8 Changed 20 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In 07b671:

Fix a possibly overflow with the CLUT size of DVB and PGS subtitles.

Because of this PGS subtitles were sometimes not displayed at all, the impact was probably negligible for DVB subtitles.

Fixes #5515.

comment:9 Changed 20 months ago by underground78

  • Milestone set to next release

Will be in the nightly builds as of version 1.7.9.57.

comment:10 Changed 17 months ago by thevbm

  • Milestone changed from next release to 1.7.10

Milestone renamed

Note: See TracTickets for help on using tickets.