Opened 21 months ago

Closed 21 months ago

Last modified 17 months ago

#5479 closed Bug (fixed)

MPC-HC don't starts (x64)

Reported by: andrés suero Owned by: underground78
Priority: high Milestone: 1.7.10
Component: General Version: 1.7.9
Severity: major Keywords:
Cc: Evaluation:

Description

The program don't finish starting, appears in the task manager but the window don't appear, this happens sometimes.

MPC-HC (64-bit)


Build information:

Version: 1.7.9 (846eff0)
Compiler: MSVC 2013 Update 4
Build date: Jun 1 2015 09:16:50

LAV Filters:

LAV Splitter: 0.65.0.9
LAV Video: 0.65.0.9
LAV Audio: 0.65.0.9
FFmpeg compiler: MinGW-w64 GCC 4.9.2

Operating system:

Name: Windows NT 6.3 (build 9600)
Version: 6.3 (64-bit)

Hardware:

CPU: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
GPU: NVIDIA GeForce GTX 670 (driver version: 9.18.13.5306)

Change History (10)

comment:2 Changed 21 months ago by andrés suero

This issue only happens with the x64 version, not with the x86

comment:3 Changed 21 months ago by underground78

  • Owner set to underground78
  • Status changed from new to accepted

I think I'm currently working on something that should fix your issue.

However I'm not completely sure that the problem itself is our fault. I see that you have ObjectDock, Start8 and Asus Xonar Phoebus running. It would be interesting to try without those and see if the problem still happens. If the problem goes away, try re-enabling those programs one by one until you find which is causing the issue.

comment:4 Changed 21 months ago by andrés suero

Start8 seems to be the problem, If I stop Start8, mpc-hc starts every time.

Last edited 21 months ago by andrés suero (previous) (diff)

comment:5 Changed 21 months ago by underground78

Not sure why they hook in every program, maybe you can report this issue to them?

In the meantime, I think starting MPC-HC with /nocrashreport should fix the problem even when Start8 is running. I am working on an improvement which should fix the issue without needing this at all. I still think Start8 is doing something wrong though and my change would just hide the problem but not really fix it.

comment:6 Changed 21 months ago by andrés suero

Reported to Start8

comment:7 Changed 21 months ago by andrés suero

If I kill Start8 or Xonar Phoebus, then the problem is resolve, stopping ObjectDock does nothing.

http://forums.stardock.com/467624/page/1/#3566665

comment:8 Changed 21 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In 49069a:

Upgrade DrDump so that the crash reporting dialog can be improved.

  • The crash reporting dialog will not be started from the crashed process anymore so that it is completely safe.
  • The crash reporting dialog now completely replaces DrDump confirmation dialog
  • MPC-HC can now be restarted from the crash reporting dialog.

Fixes #5450 and #5479.

comment:9 Changed 21 months ago by underground78

  • Milestone set to next release

This is the work-around I was talking about. It will be in the nightly builds as of version 1.7.9.47.

Last edited 21 months ago by underground78 (previous) (diff)

comment:10 Changed 17 months ago by thevbm

  • Milestone changed from next release to 1.7.10

Milestone renamed

Note: See TracTickets for help on using tickets.