Opened 22 months ago

Closed 21 months ago

Last modified 17 months ago

#5472 closed Bug (fixed)

Can't enter "-" to "Audio time shift (ms)" field

Reported by: gcraistlin Owned by: kasper93
Priority: normal Milestone: 1.7.10
Component: User Interface Version: 1.7.9
Severity: normal Keywords:
Cc: underground78 Evaluation: diagnosed

Description

Options | Audio switcher | Audio time shift (ms) accepts only digits. We're forced to use mouse to enter a negative number. Not a big deal but annoying.

Change History (14)

comment:1 follow-up: Changed 22 months ago by thevbm

You can enter it just fine. Only thing is that you can't enter it while it's on 0.
Guess it's a limitation of sort that it's not recognizing signed zero (positive or negative zero).

Last edited 22 months ago by thevbm (previous) (diff)

comment:2 Changed 22 months ago by gcraistlin

The initial value is exactly 0 most often. In this case, "-" cannot be entered - even if I want to replace the current value by selecting it. It is the senseless limitation.

comment:3 Changed 22 months ago by robert_s

You can enter "-" when it's 0. What you cannot do is select the whole field and then enter "-", as that would put a single "-" into the field - and that is not a number.

But you're not forced to use the mouse to enter a negative number: Simply press the cursor down key.

comment:4 Changed 22 months ago by robert_s

BTW, I think this is a standard Windows control. So if you're dissatisfied with how it works, do the right thing and complain to Microsoft about it ;-)

comment:5 in reply to: ↑ 1 Changed 21 months ago by underground78

  • Cc underground78 added
  • Component changed from General to User Interface

Replying to thevbm:

You can enter it just fine. Only thing is that you can't enter it while it's on 0.

I cannot reproduce this here, I can enter a - even when it's 0.

Anyway as robert_s said, this is a standard Windows control. I think gcraistlin might be using XP so it is possible that the behavior is different.

comment:6 Changed 21 months ago by kasper93

I cannot reproduce this here, I can enter a - even when it's 0.

Like robert_s said you can enter minus sign always, except when whole number is selected. And it turns out to be selected just after focusing on this control with TAB key. In this case one must to deselect number to input minus sign. But this is easily done we arrow key for example or by clearing existing numbers before inputing new ones.

I think it is standard behavior and we shouldn't change it.

Last edited 21 months ago by kasper93 (previous) (diff)

comment:7 Changed 21 months ago by gcraistlin

I think it is standard behavior and we shouldn't change it.

As I said, it's not a big deal but I should note that this "standard behaviour" does make troubles when one wishes to replace the existing value with a new one in another standard way - by selecting the existing value and typing the beginning of a new value ("-").

comment:8 Changed 21 months ago by kasper93

  • Owner set to kasper93
  • Status changed from new to assigned

Try if this build works fine for you.

It turns out this is our fault. I wasn't' aware that we use some custom thing to filter input on those edit boxes.

comment:9 Changed 21 months ago by kasper93

  • Evaluation set to diagnosed

comment:10 Changed 21 months ago by gcraistlin

The test build still doesn't allow to replace the existing negative value with "-".

comment:11 Changed 21 months ago by kasper93

Another test build hopefully this one will work fine for you.

comment:12 Changed 21 months ago by kasper93

  • Resolution set to fixed
  • Status changed from assigned to closed

In 85b7b3:

CIntEdit: Allow to input minus sign also when whole number is selected.

Based on Lord's patch.

Fixes #5472

comment:13 Changed 21 months ago by kasper93

  • Milestone set to next release

Will be in the nightly builds as of version 1.7.9.32.

comment:14 Changed 17 months ago by thevbm

  • Milestone changed from next release to 1.7.10

Milestone renamed

Note: See TracTickets for help on using tickets.