Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5401 closed Bug (fixed)

Exit WinLIRC command is bound hardly to Exit command

Reported by: gcraistlin Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: General Version: 1.7.8
Severity: normal Keywords:
Cc: Underground78 Evaluation: diagnosed

Description

If current WinLIRC configuration has a command named "Exit" and control via WinLIRC is enabled in MPC-HC pressing the corresponding button on the IR remote closes MPC-HC.

Change History (12)

comment:1 Changed 5 years ago by Underground78

Cc: Underground78 added
Evaluation: need info
Status: newevaluated

Isn't that expected? I'm not sure I understand what the problem is.

comment:2 Changed 5 years ago by gcraistlin

Of course it isn't if "Exit" RemoteCmd command isn't assigned for "Exit" Command. Now I have to rename "Exit" WinLIRC command somehow ("Exit_") to assign it to the Command I need (if it is not "Exit").

comment:3 Changed 5 years ago by gcraistlin

I mean that "Exit" RemoteCmd command isn't assigned to "Exit" Command but nevertheless performs this action.

comment:4 Changed 5 years ago by Underground78

Is there any way to emulate a remote sending those commands? I don't see anything obvious.

comment:5 Changed 5 years ago by gcraistlin

I'm afraid no. There's "Send Code" button in WinLIRC main window but it doesn't seem to work. Anyway, the issue is not related to the certain remote but to the certain name of the button. It is reproducible with button names "Exit" and "ExiT" but not "Exit_".

Last edited 5 years ago by gcraistlin (previous) (diff)

comment:6 Changed 5 years ago by Underground78

The problem is that I cannot test and I don't see anything that would cause the "EXIT" command to be handled when no command is set. :/

comment:7 Changed 5 years ago by Underground78

Evaluation: need infodiagnosed

In fact I just understood what happens here but it's weird. In fact it seems to match the command with the name of all available commands. It seems like a bad idea but I have no idea why it was done this way.

comment:8 Changed 5 years ago by gcraistlin

It's true - I checked with another button name. A bad idea, definitely.

comment:9 Changed 5 years ago by Underground78

Owner: set to Underground78
Status: evaluatedaccepted

Seems like it has always been like this... I guess I will change that.

comment:10 Changed 5 years ago by Underground78 <underground78@…

Resolution: fixed
Status: acceptedclosed

In 9da8f30:

Fix: Correctly check remote commands.

There is no reason to match the remote command against the commands' names.

Fixes #5401.

comment:11 Changed 5 years ago by Underground78

Milestone: next release

Will be in the nightly builds as of version 1.7.8.173.

comment:12 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.