Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5392 closed Bug (fixed)

Deadlock when using the ISR with madVR

Reported by: TheRyuu Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: Subtitles Version: nightly, specify
Severity: normal Keywords: ISR, madVR
Cc: Evaluation: diagnosed

Description

mpc-hc deadlocks when using the ISR set to "Video" resolution with madVR. This can also apparently manifest itself as subtitles not showing up (instead of deadlocking) although I have not been able to reproduce it that way. Using a different renderer like EVR-CP works as expected as does manually setting the subtitle resolution to the video resolution (e.g. 1280x720).

Steps to reproduce:
1.) Have a mkv file with ass subtitles available, any should do. I've only tried this with 1280x720 files.
2.) Set the ISR to "Video" resolution and the renderer to madVR. Other settings shouldn't matter.
3.) madVR settings also shouldn't matter but I would avoid using any of the image doubling stuff for this test, just regular resizers (I use jinc3ar for luma/chroma).
4.) Open the file, it will deadlock when the first subtitle is timed to appear (video will freeze, audio should continue playback).

This should occur with the 32 or 64-bit version. I'm not sure if this is an issue in mpc-hc or madVR. I can open a ticket for madVR if nessasary but I figured I should start here. This has occured since at least 2014-12-25 (on the developer branch).

Change History (10)

comment:1 Changed 5 years ago by TheRyuu

I should've set this as nightly instead of 1.7.8.

Basically take your pick of any developer branch build between 20141225 and now and you should be able to reproduce this. I'll be shocked if you can't.

comment:2 Changed 5 years ago by Underground78

Owner: set to Underground78
Status: newaccepted

Confirmed, I will have a closer look now.

comment:3 Changed 5 years ago by xhmikosr

Version: 1.7.8nightly, specify

comment:4 Changed 5 years ago by Underground78

Evaluation: diagnosed

Yeah, something was indeed overlooked here (possibly from the beginning).

@TheRyuu: Do you remember if this ever worked?

comment:5 Changed 5 years ago by Underground78

Status: acceptedreviewing

Can you try that everything works as expect with this test build?

comment:6 Changed 5 years ago by TheRyuu

No I don't remember it ever working with madVR but I don't use it (ISR) that much.

Can you provide the patch for that as well? I'll test it later.

comment:7 Changed 5 years ago by TheRyuu

Nevermind about the patch.

Just tested that test build and it seems to work fine now.

comment:8 Changed 5 years ago by Underground78 <underground78@…

Resolution: fixed
Status: reviewingclosed

In 915966b:

Fix the ISR when the max resolution is set to "video" and madVR is used.

Fixes #5392.

comment:9 Changed 5 years ago by Underground78

Milestone: next release

Will be in the nightly builds as of version 1.7.8.167.

comment:10 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.