Opened 5 years ago

Closed 3 years ago

#5336 closed Feature Request (fixed)

Improve "Reporting a bug" page

Reported by: clsid2 Owned by:
Priority: normal Milestone:
Component: General Version: 1.7.8
Severity: normal Keywords:
Cc: Evaluation:

Description

I see a lot of dump reports for old versions and reports without any details at all. I think we can improve the quality of the reports by giving the users more detailed instructions on how and when to submit a ticket.

The current instructions on the bug report url are very short.
https://trac.mpc-hc.org/wiki/How_to_Report_Issues

I suggest adding something like:

STEPS TO TAKE BEFORE SUBMITTING A BUG REPORT

1) Download and test the latest nightly build. Your problem might have already been fixed by us.
http://nightly.mpc-hc.org/
The .7z archives (which can be opened with WinRAR or 7-Zip) require no installation.

2) Reset the settings.
Options > Miscellaneous > Settings management > Reset

3) Update your sound and graphics drivers.

HOW TO SUBMIT A BUG REPORT

Include the instructions on how to create a trac account and how to open a ticket.

WHAT INFORMATION TO INCLUDE IN A BUG REPORT

Information is extremely important, because the developers need to be able to reproduce a report to be able to fix it! bla bla bla

(basically move the info from https://trac.mpc-hc.org/wiki/How_to_Write_Reports to the main bug report page, to make sure people actually need it)

1) Include any .dmp files generated by MPC-HC during a crash.
+ location of dump folder

2) A clear description of your problem.
In case of a crash, tell use when it happened. For example while opening a file, when closing the player, when seeking, etc.

3) If you problem only occurs with specific files, then a sample file would be very helpful to us.
You can upload a sample file to a file storage website and put the link in your reports. Good free sites to upload a file to are:
http://www.datafilehost.com
(add other sites)

If the file is very large, then you can cut a piece with this little tool:
http://neuron2.net/dgsplit/dgsplit12.zip
A 30MB sample is a good size. Please test if the cut sample still has the same problem as the whole file before you upload it.

(If you downloaded the file from a public torrent, then you also put the link here so we can download it ourselves.)

4) Provide details about your system:

  • Which version of MPC-HC
  • Which version of Windows
  • Which graphics card and which driver
  • Which CPU (in case of performance related issues)

Change History (3)

comment:1 Changed 5 years ago by Underground78 <underground78@…

In cdbdc9:

Replace our custom minidump generation code by Doctor Dump.

Doctor Dump is a more advanced crash reporter with crash report uploading and a server-side application to sort and keep track of them.

See ticket #5336 also fixes #5380.

comment:2 Changed 5 years ago by Underground78

Cc: Underground78 added

It doesn't cover everything you mentioned but it's a first step for easier crash reporting.

comment:3 Changed 3 years ago by clsid2

Cc: Underground78 removed
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.