Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5333 closed Bug (fixed)

No sound when BD is being played via index.bdmv

Reported by: gcraistlin Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: General Version: 1.7.8
Severity: normal Keywords:
Cc: Underground78, kasper93 Evaluation: reproduced

Description

I've a BD the main m2ts file of which can be played fine in MPC-HC. But if we open the BD via index.bdmv or the corresponding playlist and then jump to some time position the sound disappears. Ready to give any info / upload required files. Or you can download this BD yourself: http://rutracker.org/forum/viewtopic.php?t=2136291

Change History (12)

comment:1 Changed 5 years ago by Underground78

Cc: Underground78 added
Evaluation: need info
Status: newevaluated

Is it specific to this BD?

comment:2 Changed 5 years ago by gcraistlin

Yes. Just tried another one - sound is OK after time jump.

comment:3 Changed 5 years ago by Underground78

Could you pack all files expect the m2ts in an archive and upload it?

comment:4 Changed 5 years ago by kasper93

Cc: kasper93 added
Evaluation: need inforeproduced

I can indeed reproduce the issue. It fails to recover on seek and strange things happen. Will debug it.

Replying to underground78:

Could you pack all files expect the m2ts in an archive and upload it?

As requested https://www.dropbox.com/s/er191mdeolkywzw/Ticket5333.7z

Last edited 5 years ago by kasper93 (previous) (diff)

comment:5 Changed 5 years ago by Underground78

@kasper: On the same BD? (I was not even able to find how to get the torrent.)

comment:6 Changed 5 years ago by kasper93

Yes, on the same one. (You need to be logged in to get it)

I think first thing I will do is to update libbluray. Maybe this will be a lucky day and this is fixed ;p (but it is more likely integration bug rather than lib itself)

Last edited 5 years ago by kasper93 (previous) (diff)

comment:7 Changed 5 years ago by Underground78

Hmm I wouldn't bet that the playlist itself is not buggy. For example, if you compare the duration when starting the m2ts and when using the playlist, is it the same?

comment:8 Changed 5 years ago by gcraistlin

Yes it is: 01:48:48.

comment:9 Changed 5 years ago by kasper93

I'm not saying playlist is bugged, but seeking is handled by libbluray and this is difference to the .m2ts opening. Well I will tell if I find something, but it is late today and well I got side-tracked by other things so probably tomorrow.

Last edited 5 years ago by kasper93 (previous) (diff)

comment:10 Changed 5 years ago by Underground78 <underground78@…

Owner: set to Underground78 <underground78@…>
Resolution: fixed
Status: evaluatedclosed

In c70269:

Updated LAV Filters to 0.64-38-cd85522 (custom build based on 0.64-32-93ea8fe).

Important changes:

  • LAV Video Decoder: Support FLIC looping
  • LAV Video Decoder: Improve DVD subtitles timeout in some cases (fixes #5330)
  • LAV Audio Decoder: Switch to libdcadec decoder for DTS decoding
  • LAV Splitter: Fix handling of some Blu-Ray playlist (fixes #5333)
  • LAV Splitter: Improve handling of embedded subtitles for MKV files created with recent versions of mkvtoolnix: subtitles will now be properly shown immediately after seeking if need be
  • Updated FFmpeg library

comment:11 Changed 5 years ago by Underground78

Milestone: next release
Owner: changed from Underground78 <underground78@… to Underground78

Will be in the nightly builds as of version 1.7.8.115.

comment:12 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.