Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5241 closed Bug (fixed)

Dock bars do not support right-to-left layout

Reported by: Stamimail Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: User Interface Version: 1.7.7
Severity: normal Keywords:
Cc: Evaluation: need info

Description

It is not aligned as expected while moving and resizing.

Attachments (7)

MPC.PNG (91.6 KB) - added by Stamimail 5 years ago.
video_capture.mp4 (387.1 KB) - added by Underground78 5 years ago.
1.PNG (96.0 KB) - added by Stamimail 5 years ago.
2.PNG (51.4 KB) - added by Stamimail 5 years ago.
3.png (85.9 KB) - added by Stamimail 5 years ago.
4.PNG (175.2 KB) - added by Stamimail 5 years ago.
Everything Search.PNG (282.1 KB) - added by Stamimail 5 years ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 5 years ago by Underground78

Cc: Underground78 added
Component: GeneralUser Interface
Evaluation: need info
Status: newevaluated

Could you please give more details and maybe add screenshots?

Changed 5 years ago by Stamimail

Attachment: MPC.PNG added

comment:2 Changed 5 years ago by Stamimail

I can't set it as expected. Half or a third of the window.

comment:3 Changed 5 years ago by Underground78

I don't get what you mean. Do you mean that you can't resize it to the size you want?

comment:4 Changed 5 years ago by Stamimail

Like the picture. Try to expand the playlist.

Changed 5 years ago by Underground78

Attachment: video_capture.mp4 added

comment:5 Changed 5 years ago by Underground78

I see nothing wrong with the playlist, cf. the attached screen capture.

comment:6 Changed 5 years ago by Stamimail

Thank you for adding video_capture.mp4​
In my system it doesn't work.
How to solve this problem in my system?
W7 x64 Ultimate. Hebrew.
This problem is still there even after upgrade.

comment:7 Changed 5 years ago by Underground78

Can you confirm that it works fine if you switch MPC-HC to English (restart it after doing that so that the left to right layout is used)?

comment:8 Changed 5 years ago by Stamimail

Yes, In English it works. Need an improvement IMHO but works.
I checked both x64 x86 ...

Last edited 5 years ago by Stamimail (previous) (diff)

comment:9 Changed 5 years ago by Underground78

Could you try this test build (using Hebrew translation) and report back any weird behavior?

comment:10 Changed 5 years ago by Stamimail

  1. Now it works. But still, as I said for the english version it needs to be improved, IMHO. Design and the way of its behaviour (It's not so well as Windows Aero for example).
  2. There are some little problems. see 1,2 pics.
  3. There is also problem with the LIve Preview Window buttons. It should be in LTR order as English. see 3,4 pics.

BTW, You forgot to put Lang folder in the test build. I copied this folder to have languages available...

Changed 5 years ago by Stamimail

Attachment: 1.PNG added

Changed 5 years ago by Stamimail

Attachment: 2.PNG added

Changed 5 years ago by Stamimail

Attachment: 3.png added

Changed 5 years ago by Stamimail

Attachment: 4.PNG added

comment:11 Changed 5 years ago by Underground78

I need your opinion about the docking bars when using the Hebrew translation (so with a right to left layout):

  1. If the bar was docked at the left when using left to right layout, should it stay on the left when using the right to left layout or should it be mirrored and thus be on the right?
  2. Should the vertical grip (currently broken, appearing black near to the arrow on your picture 1.png) stay on the left or be mirrored on the right when using the right to left layout?

I'm not sure what other software using do in that regard.

comment:12 Changed 5 years ago by Stamimail

IMHO:

  1. The default behaviour should be mirrored. Placed on the right.
    In general, I can say, it depends on whether the Playlist is in Hebrew or English.
    We have both English and Hebrew FileNames. So when the Playlist is in Hebrew, the user would prefer the Playlist aligned to the Right, and when the Playlist is in English he would prefer it aligned to the Left.
    I know "Everything Search" let the RTL user to toggle between RTL and LTR view of the Folders&Files list (by MenuContext and Shortkey). I think making such feature in MPC for the RTL users would be the best from the RTLs point of view.
  2. The vertical grip should be mirrored to whatever LTR is. If in LTR is on the left, so in RTL it should be on the Right.

Changed 5 years ago by Stamimail

Attachment: Everything Search.PNG added

comment:13 Changed 5 years ago by Underground78

I have fixed all issues with the dockable bars (playlist, etc.) but I don't really understand your issue with the task bar buttons. It's not RTLed on my computer. Are you sure that it's RTLed only when using the Hebrew translation on your computer? I would suspect it's something Windows does no matter if we switch MPC-HC to RTL layout or not.

comment:14 Changed 5 years ago by kasper93

Maybe windows by design mirror it to look LTR on all applications. That say maybe we should RTL this and windows will turn it back.

comment:15 Changed 5 years ago by Underground78

Well here it's LTR even when I have MPC-HC RTLed because I switched to Hebrew so it's weird.

comment:16 Changed 5 years ago by Underground78

As far as I can tell the window corresponding to the task bar thingy isn't even part of MPC-HC. It's a system window that is repurposed depending on the hovered item. I'm not completely sure how to handle that correctly but I will think about it.

comment:17 in reply to:  13 ; Changed 5 years ago by Stamimail

Replying to underground78:

I have fixed all issues ...

---
Yes, you are right. The Live Preview buttons are in RTL order even when I run MPC-HC in English. It seems to be related to the RTL operating system. Anyway, it's incorrect. No matter if the OS is LTR/RTL, and not matter if the layout of MPC-HC is LTR/RTL, the Seek bar and the Live Preview buttons should be in LTR order.
If I'm not mistaken, I would say, only text-related components should be RTLed.

comment:18 Changed 5 years ago by Underground78

Are you sure that the same doesn't happen with WMP? Since there are only three buttons, it could very well be RTLed too without it being too obvious. Have you tried using them to make sure Next/Previous are not inverted?

Last edited 5 years ago by Underground78 (previous) (diff)

comment:19 Changed 5 years ago by Underground78

Summary: Play List Window Ctrl+7 should be fixedDock bars do not support right-to-left layout

Just found out that #1912 was the same than this ticket and that you already reported the issue with the task bar: #2167. We will use this ticket for the dock bars and keep #2167 opened for the task bar.

comment:20 in reply to:  18 Changed 5 years ago by Stamimail

Replying to underground78:

Are you sure that the same doesn't happen with WMP? Since there are only three buttons, it could very well be RTLed too without it being too obvious. Have you tried using them to make sure Next/Previous are not inverted?

Yes. In WMP the Live Preview buttons are OK, The Left is preivous, The Right is Next.
For #2167 I think some was deleted. I don't see my attachment. It was 3.png

comment:21 in reply to:  17 Changed 5 years ago by Underground78

The attachment in #2167 works fine for me. I will repost you message there, answer in this other ticket for everything about the task bar from now on.

Last edited 5 years ago by Underground78 (previous) (diff)

comment:22 Changed 5 years ago by Underground78 <underground78@…

Owner: set to Underground78 <underground78@…>
Resolution: fixed
Status: evaluatedclosed

In 8818e0:

Sizecbar: Improve the handling of RTL layout.

Both Arabic and Hebrew translations use RTL layout which was quite badly handled by the dockable bars (Playlist, Subresync, etc.).

This commit fixes:

  • resize when the bar was docked at the left or the right of the main window
  • incorrect display of the bars docked at the top and the bottom.

Fixes #5241.

comment:23 Changed 5 years ago by Underground78

Cc: Underground78 removed
Milestone: next release
Owner: changed from Underground78 <underground78@… to Underground78

Will be in the nightly builds as of revision 1.7.8.28.

comment:24 Changed 5 years ago by Stamimail

Thank You very much
Stamimail

comment:25 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.