Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5183 closed Bug (fixed)

1.7.7 (64-bit) crashes frequently while playing MIDI file

Reported by: bege10 Owned by: kasper93
Priority: normal Milestone: 1.7.9
Component: General Version: 1.7.7
Severity: normal Keywords:
Cc: Evaluation: diagnosed

Description

MPC-HC 1.7.7 (64-bit) crashes frequently (not always) when playing a MIDI audio file.

Attachments (4)

mpc-hc64.exe.1.7.7.dmp (68.4 KB) - added by bege10 5 years ago.
mpc-hc64.exe.1.7.8.dmp (264.8 KB) - added by bege10 5 years ago.
dump file of 1.7.8
J0074327.MID (3.1 KB) - added by bege10 5 years ago.
MIDI file
mpc-hc64.exe.1.7.8.2.dmp (263.1 KB) - added by bege10 5 years ago.
I did as clsid2 suggested. The result is another dump file. (When I posted this thread mpc-hc crashed at various places during playing. Since 1.7.7.beta if it crashes it happens after playing has finished.)

Download all attachments as: .zip

Change History (25)

Changed 5 years ago by bege10

Attachment: mpc-hc64.exe.1.7.7.dmp added

comment:1 Changed 5 years ago by bege10

Additional information: The crash happens at various positions during playing, not always at the same position.

comment:2 Changed 5 years ago by Underground78

Cc: Underground78 added
Evaluation: need info
Status: newevaluated

Could you please try the latest beta? Upload the new dump if you get one.

I can't understand what happens here so either it's a very bizarre bug or there is a problem with the dump.

comment:3 Changed 5 years ago by kasper93

Cc: kasper93 added

Please provide dump generated with this build. Zip it and send to your favorite file hosting.

You can skip latest beta test requested by @Underground78, build provided by me is based of the same code, but will generate full memory dump which hopefully give us better insight into the problem.

comment:4 Changed 5 years ago by bege10

Thank you for the provided download. I installed it and will come back after the next crash.

comment:5 Changed 5 years ago by bege10

I didn't have any crashes any more.
After having installed the build provided by kasper93 the file browser opens with the mpc-hc install folder and Internet browser with the bug tracker after mpc-hc closes. I think this is intentionally for debugging.
Now I have installed the official version 1.7.8 and the described behavior remains. How can I stop mpc-hc from opening the file and Internet browsers?
Thank you.

comment:6 Changed 5 years ago by Underground78

It means that MPC-HC is still crashing. Please attach the dump file that was created.

Changed 5 years ago by bege10

Attachment: mpc-hc64.exe.1.7.8.dmp added

dump file of 1.7.8

comment:7 Changed 5 years ago by bege10

dump file of special download 1.7.7 provided by kasper93
http://www.file-upload.net/download-10272693/mpc-hc64.exe.1.7.7.160.dmp.html

comment:8 Changed 5 years ago by kasper93

I'm busy today. I will take a look tomorrow. Here are PDB files for my build if anyone else wants to look before https://www.dropbox.com/s/yb6j8mxat8nxxdv/MPC-HC.1.7.7.160.x64.pdb.7z?dl=1

comment:9 Changed 5 years ago by Underground78

No change compared to earlier, I'm pretty sure there is some memory corruption going one.

Could you please tell us which filters are used to play this MIDI file (see "Play > Filters" menu)? Also it would be create if you could share that MIDI file with us.

comment:10 Changed 5 years ago by bege10

Filters currently loaded:

  • Default MidiOut Device
  • MIDI Parser
  • File Source (Async.)

Changed 5 years ago by bege10

Attachment: J0074327.MID added

MIDI file

comment:11 Changed 5 years ago by kasper93

Owner: set to kasper93
Status: evaluatedassigned

comment:12 Changed 5 years ago by kasper93

Evaluation: need infodiagnosed

comment:13 Changed 5 years ago by Underground78

Seems like kasper was able to reproduce the problem but at least I couldn't so far.

comment:14 Changed 5 years ago by clsid2

Delete this registry key
HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum 64-bit\{4EFE2452-168A-11D1-BC76-00C04FB9453B}

Then launch the command prompt as administrator and execute this command:
regsvr32 devenum.dll

This will reset the midi device list.

comment:15 Changed 5 years ago by kasper93

And how this is related?

comment:16 Changed 5 years ago by clsid2

That procedure has solved MIDI playback troubles for others, so it may help in this case as well.

Changed 5 years ago by bege10

Attachment: mpc-hc64.exe.1.7.8.2.dmp added

I did as clsid2 suggested. The result is another dump file. (When I posted this thread mpc-hc crashed at various places during playing. Since 1.7.7.beta if it crashes it happens after playing has finished.)

comment:17 Changed 5 years ago by Underground78

The problem has been solved, the fix will be in the next beta version (which should be out soon).

comment:18 Changed 5 years ago by kasper93

Sorry I wasn't clear enough. By setting ticket status to "diagnosed" it means that it is diagnosed and fix is ready or will be ready soon.

@clsid2: We should refrain from giving random tips based only on description. Crash is not MIDI related and you would have know if you looked and crash dump instead of posting random registery edit...

comment:19 Changed 5 years ago by kasper93

Resolution: fixed
Status: assignedclosed

In b47ab1:

CMainFrame: Abort graph messages processing if app is exiting.

Fixes #5183

comment:20 Changed 5 years ago by kasper93

Cc: Underground78 kasper93 removed
Milestone: next release

Will be in the nightly builds as of revision 1.7.8.38.

comment:21 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.