Opened 6 years ago

Closed 5 years ago

#422 closed Bug (invalid)

MPC choppy when moving slider

Reported by: janlafata Owned by:
Priority: normal Milestone:
Component: General Version: 1.3.1249
Severity: major Keywords: Choppy, Nvidia
Cc: deltasquad49 Evaluation:

Description

I have Windows 7 x64. I use Media Player Classic x32 as my default video player. Usually after I put together a new avi file, I like to play it back to check in in MPC. I also like to check the video ahead in parts for correct audio syncing etc. In the past when I did this, there was no pause or freeze in the video when I did it, but lately, I will move the slider ahead some, then I will see the video temporarily freeze, then jump a few seconds. It does not do this when I check a video in WMP. I don't believe it's a codec problem, but then again, you never know, but all I have is AC3, XviD and DivX installed. I have toyed with the idea of running the x64 MPC, but when I tried it a few months ago I had some problems.

Change History (11)

comment:1 Changed 6 years ago by deltasquad49

I have the same exact problem, but I am using Windows 7 x86. It happens mostly with .flv for me, but will play perfectly in WMP.

comment:2 follow-up: Changed 6 years ago by janlafata

Don't know if this will help you or anyone else but I think I found a solution, at least in my case. I did some searching on this issue and read where if you tweak something in the NVidia Control Panel it might clear it up. Of course this would only apply if you were using an NVidia chip video card and possibly only on certain cards. I don't know if you could do the same thing with an ATI card or not. though.

Here's what I did: I opened up the NVidia Control Panel and went to "Adjust video image settings".Under "Edge enhancement" I switched it from "Use the video player settings" to "Use the Nvidia settings" and it worked! No more freezing up or choppiness after I move the slider ahead. Hope that helps!

comment:3 Changed 6 years ago by deltasquad49

  • Component changed from New to Fix created

This does work! Thank you janlafata! I would have never found that, btw my driver version was 197.xx and even updated to 197.45 with no success until I changed that setting. Thanks a million!

comment:4 Changed 6 years ago by tetsuo55

  • Cc deltasquad49 added
  • Component changed from Fix created to Need Info

You seem to both be using Nvidia,

Does downgrading your videocard driver to 196.21 also solve the problem while leaving that controlpanel setting at the default "use application settings value"

Also are you using EVR-CP or an other renderer, how do other renderers behave?

comment:5 Changed 6 years ago by paleowyn

  • Keywords Choppy Nvidia added
  • Version set to 1.3.1249

Hi, I got the exact same problem.

MPC-HC version : 1.3.1249
PC Configuration: Windows 7 - x64
Graphic card : Nvidia GTX 275 - driver version 197.45

Vidéo (XVID/DIVX) becomes choppy when moving slider. Sometimes, the video is choppy without event moving the slider, so as soon as the video start.
What strange is that there is no pb with H.264 video.
This happens only if EVR CP is selected.

Video is never choppy if VMR9 renderless is selected.
Problem is that VRM9 renderless does not seems to accept/trigger DVXA on my configuration.

Tried MPC-HC x64, and got no problem. However, I reverted back to x86 version as x86 codecs are not compatible with MPC-HC x64.

Problem solved using trick ahead, however, I changed "Noise Reduction" from "Use the application settings" to "Use the nvidia settings" rather than changing "Edge enhancement" as the quality was quite bad with that last parameter changed.

I am wondering is there is not a conflict when running MPC-HC x86 on a 64 bits system, or 64 bits graphic card driver.

comment:6 Changed 6 years ago by deltasquad49

I still have problems with choppiness on both VMR9 and EVR CP. I am not sure what triggers it every time. Sometimes flash videos will freeze but sound will continue when exiting fullscreen also.

I will try using old drivers later and test it out. Again, I am using 32 bit Windows 7.

comment:7 in reply to: ↑ 2 Changed 6 years ago by magicmau

Replying to janlafata:

Don't know if this will help you or anyone else but I think I found a solution, at least in my case. I did some searching on this issue and read where if you tweak something in the NVidia Control Panel it might clear it up. Of course this would only apply if you were using an NVidia chip video card and possibly only on certain cards. I don't know if you could do the same thing with an ATI card or not. though.

Here's what I did: I opened up the NVidia Control Panel and went to "Adjust video image settings".Under "Edge enhancement" I switched it from "Use the video player settings" to "Use the Nvidia settings" and it worked! No more freezing up or choppiness after I move the slider ahead. Hope that helps!

Thank you very much !!! you saved my day ! forgot about that option. i think the problem is there only with latest nVidia drivers.

Bye !

comment:8 Changed 6 years ago by magicmau

EDIT: I'm sorry to say that the problem is still there. This workaround didn't work for me :-(

comment:9 Changed 6 years ago by clsid2

Get the latest NVIDIA beta driver (v247)

comment:10 Changed 6 years ago by namaiki

Any changes with the latest drivers?

comment:11 Changed 5 years ago by namaiki

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.