Opened 6 years ago

Closed 6 years ago

#4208 closed Bug (invalid)

Crach when I setting the video decode

Reported by: eidk2014 Owned by: Underground78
Priority: normal Milestone:
Component: Internal Filters Version: nightly, specify
Severity: normal Keywords:
Cc: Evaluation:

Description

http://www.uploadfr.com/images/2014/04/10/2GXHf.jpg

Attachments (1)

mpc-hc.exe.1.7.3.201.dmp (51.3 KB) - added by eidk2014 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by eidk2014

Attachment: mpc-hc.exe.1.7.3.201.dmp added

comment:1 Changed 6 years ago by eidk2014

Oh, this is the filters I update.
http://www.sendspace.com/file/io76zs

Last edited 6 years ago by eidk2014 (previous) (diff)

comment:2 Changed 6 years ago by armada651

So you've replaced the internal LAV Filter DLLs with your own versions?

comment:3 in reply to:  2 Changed 6 years ago by eidk2014

Replying to armada651:

So you've replaced the internal LAV Filter DLLs with your own versions?

yes. anything wrong? the internal is old, so i updated a new git=_=

comment:4 Changed 6 years ago by Underground78

Component: GeneralInternal Filters
Owner: set to Underground78
Status: newaccepted

In theory it should work though we don't really recommend to do that.

In that case it's quite strange because it seems to happen for the video decoder only. I will have a closer look.

comment:5 Changed 6 years ago by Underground78

Run-Time Check Failure #0 - The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention.

It would seem to be a compilation issue, either a miscompilation though it seems a bit unlikely or just a compatibility issue with another version of the compiler (it surprises me too to be honest).

Edit: What's strange too is that it doesn't happen for all functions...

Last edited 6 years ago by Underground78 (previous) (diff)

comment:6 Changed 6 years ago by alexmarsev

It may be possible if we use hard casts on COM objects instead of QueryInterface.

comment:7 Changed 6 years ago by Underground78

I don't think we do that but I will double check.

Also the official build (same revision than eidk2014's) works perfectly fine.

comment:8 in reply to:  description ; Changed 6 years ago by alexmarsev

Replying to eidk2014:
Could you provide your build environment detailed description?
Or maybe you modified lav source code somehow?

comment:9 in reply to:  8 Changed 6 years ago by eidk2014

Replying to alexmarsev:

Replying to eidk2014:
Could you provide your build environment detailed description?
Or maybe you modified lav source code somehow?

I have sent a message to the programmer just now.
Or maybe you can get help from these files.

comment:10 Changed 6 years ago by Underground78

Resolution: invalid
Status: acceptedclosed

The problem is 0002-Add-an-option-to-try-DXVA2-native-first-and-fall-bac.diff. It breaks compatibility with the official programming interface. Tell him to add his custom methods at the end of the interfaces, it should work.

There is nothing we can do on our side so I'm closing this ticket. You can still add new comments of course.

Note: See TracTickets for help on using tickets.