Opened 3 years ago

Closed 20 months ago

Last modified 17 months ago

#4086 closed Bug (fixed)

LCD DISPLAY

Reported by: fox bauer Owned by: underground78
Priority: normal Milestone: 1.7.10
Component: User Interface Version: 1.7.3
Severity: normal Keywords:
Cc: Evaluation:

Description

Congratulations for MPC, the best ever PC Windows Player, since mplayer.exe for Windows 2000, or before? jajaja!
I'm a Systems Engineer's of 40 years old! jejeje! (sorry about my suck english!) ;)
This is about Logitech's LCD support.
Because, when I open a "file" in 1.7.3, then the left bar on the LCD screen that shows the audio volume of the file, is empty, although the audio volume of the loaded file it's the highest, 100%.
I must to press once the "UP" key to fill this bar full in the LCD screen. Then it works perfectly.
I say this one because in older versions of the program, it didn't happen.
I don't know which version exactly was (now I have a G510 one), but I DO confirm you that this problem in olver versions it didn't happened (maybe it was when I had a G15 one).

I would like if you could fix this.

Greetings

Zabas

Change History (7)

comment:1 Changed 3 years ago by xhmikosr

  • Milestone next release deleted
  • Priority changed from highest to normal
  • Severity changed from critical to normal

comment:2 Changed 20 months ago by psxlover

The problem is that the volume is never initialized.
In LcdSupport.cpp lines 294 for the color lcd and 489 for the monolcd, the progress bar that displays the volume is initialized to 0.

SetVolume is only called when the volume changes, so unless there is a change it stays 0.
It should probably be called when the volume has been initialized.

Volume range is initialized in MainFrm.cpp line 785, if m_wndToolBar is initialized "m_Lcd.SetVolume((m_wndToolBar.Volume > -10000 ? m_wndToolBar.m_volctrl.GetPos() : 1));" should be called just after that.

comment:3 Changed 20 months ago by underground78

  • Owner set to underground78
  • Status changed from new to accepted
  • Type changed from Feature Request to Bug

comment:4 Changed 20 months ago by Underground78 <underground78@…

  • Resolution set to fixed
  • Status changed from accepted to closed

In 32432b:

Logitech LCD: Correctly initialize the volume at start-up.

Fixes #4086.

comment:5 Changed 20 months ago by underground78

  • Milestone set to next release

Will be in the nightly builds as of version 1.7.9.120.

comment:6 Changed 20 months ago by psxlover

Thank you, it works like a charm now.

comment:7 Changed 17 months ago by thevbm

  • Milestone changed from next release to 1.7.10

Milestone renamed

Note: See TracTickets for help on using tickets.