Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3793 closed Bug (fixed)

MPC since version 1.7.1 does not play some ts-videos

Reported by: yabegu Owned by: Underground78
Priority: normal Milestone: 1.7.2
Component: Internal Filters Version: 1.7.1
Severity: normal Keywords: ts
Cc: Evaluation:

Description

Hello.
Starting with version 1.7.1, I can not watch some ts-videos.

MPC waits for some time (for a complete movie - wait a very long time), and then starts to play the sound, and the picture shows the last frame.

In version 1.7.0 everything was fine.

Sample which is cut from the movie: http://www.4shared.com/file/PDpTWCpo/Lilyhammer_sample.html
MD5: 526c9e7e76b477c7e720f65ab0392023
SHA-1: 452499c82211d90dc4cd6c963d6c5524154c6de1
If there is a problem with downloading, tell me where to upload 55 MB file.

System:
Windows 7 x64, MPC x64.

Change History (6)

comment:1 Changed 6 years ago by yabegu

ts-video = MPEG transport stream

Last edited 6 years ago by yabegu (previous) (diff)

comment:2 Changed 6 years ago by Underground78

Component: GeneralInternal Filters
Owner: set to Underground78
Status: newaccepted

I can confirm the issue, it seems to be an issue with the ffmpeg library we use for decoding. I have reported the issue to them so wait and see: https://trac.ffmpeg.org/ticket/3186.

comment:3 Changed 6 years ago by Underground78

The issue has been fixed on ffmpeg side, waiting for the updated library to be used in LAV Filters so that MPC-HC can in turn update. :)

comment:4 Changed 6 years ago by yabegu

Thank you and to ffmpeg developers :)

comment:5 Changed 6 years ago by Underground78 <underground78@…

Resolution: fixed
Status: acceptedclosed

In 44784773db07c434e92224ca8ab550f284fe15ea:

Update LAV Filters to 0.59.1-57-80f1385 (custom build based on 0.59.1-52-0b90b46).

Important change:

  • Update libraries (ffmpeg, libspeex, Opus, opencore-amr).
  • LAV Video decoder: Fix a decoding issue with some H264 files (fixes #3793).

Also fixes #3785.

comment:6 Changed 6 years ago by Underground78

Milestone: next release

Will be in the nightly builds as of version 1.7.1.196.

Note: See TracTickets for help on using tickets.