#3675 closed Bug (fixed)

Nvidia Surround makes player freeze

Reported by: Zektor Owned by:
Priority: normal Milestone:
Component: General Version: 1.7.0
Severity: normal Keywords: nvidia surround
Cc: JellyFrog, vaskie, kasper93 Evaluation:

Description

Ever since I updated to Windows 8.1 I haven't been able to play video files. I can load the application, but as soon as I open a video file to play, the program does not respond, and I have to force quit the app. I have updated my nvidia drivers and downloaded the latest MPC-HC player, but nothing seems to help.

When I was running windows 8, everything played fine.

I am able to play MP3 files.

I also looked in the AppData/Roaming/Media Player Classic folder for any type of .dmp file, but there is nothing there.

I hope that you are able to help.

Thanks, Scott

Change History (26)

comment:1 Changed 22 months ago by underground78

Have you tried another video renderer in the Output page of the options?

comment:2 Changed 22 months ago by Zektor

That worked. I think it's something with nvidia surround and/or sli. When I disabled surround I was able to play videos fine, but when I enabled surround I have the issue. With changing the renderer I’m now able to play everything with surround enabled.


Thanks for the help.

comment:3 Changed 22 months ago by JellyFrog

I can confirm this.

Nvidia 331.65, works fine with EVR, but with EVR-CP it hangs.
So seems like something with DXVA...

comment:4 Changed 22 months ago by underground78

What about EVR-CP with DXVA disabled?

comment:5 Changed 22 months ago by Zektor

Are you talking about "Video Mixing Renderer 9 (renderless)"? If so, I still get the program locking up and not responding. If not, how do I disable DXVA?

comment:6 Changed 22 months ago by underground78

Go to Options > Internal filters > Video decoder and disable DXVA then try again EVR-CP.

comment:7 Changed 22 months ago by Zektor

I went to Options > Internal filters > Video decoder and changed the "Hardware Decoder to use:" to "none" and I still have the same issues with EVR-CP. :(

comment:8 Changed 22 months ago by underground78

Is the problem new with NVIDIA driver 331.65?

comment:9 follow-up: Changed 22 months ago by truexfan81

underground78 on my machine win8.1 with NVidia 331.65 dxva and evr-cp works just fine.

comment:10 in reply to: ↑ 9 Changed 22 months ago by Zektor

Replying to truexfan81:

underground78 on my machine win8.1 with NVidia 331.65 dxva and evr-cp works just fine.

Are you using nvidia surround? Mine works fine when not in surround, but when I enable surround I run into issues.

comment:11 Changed 22 months ago by underground78

It looks like the same issue than #3527.

comment:12 Changed 22 months ago by truexfan81

no, I don't have enough screens to use surround

comment:13 Changed 22 months ago by underground78

Well then it's normal that it works for you, doesn't it?

comment:14 Changed 22 months ago by Zektor

Yes, it looks like it's the same issues as #3527. But just to point out, the latest official nvidia drivers do not fix this issue.

And just to be clear, this only is a problem with nvidia surround. When not using surround everything works as normal.

comment:15 Changed 22 months ago by underground78

@Zektor: Could you report the problem to them? I would think it's a problem on their side.

comment:16 Changed 22 months ago by Zektor

Will do.

comment:17 Changed 22 months ago by JellyFrog

20:45:56 < TGMP203> I can't seem to get MPC-HC to play anything... it just hangs when trying.
20:47:14 <+Jellyfrog> you got nvidia?
20:47:16 <+Jellyfrog> with surround?
20:47:19 < TGMP203> Yes

Just for the record

comment:18 Changed 22 months ago by JellyFrog

  • Keywords nvidia surround added
  • Summary changed from Windows 8.1 MPC-HC Videos wont play. Player Not Responding to Nvidia Surround makes player freeze

comment:19 Changed 22 months ago by JellyFrog

Same problem: #3774

comment:20 Changed 22 months ago by vaskie

System:
3x Geforce 580 GTX (3x portrait 3240x1920 nvidia surround driver version: 331.82)
8G RAM
Windows 7 64 bit

mpc-hc is starting in a paused state for any video I play(mkv, avi, mpeg). I can press play but it still does not start the video. If I try to advance the slider for the video it freezes and becomes none responsive until I force close it. I tried uninstalling and reinstalling with same result. Video renderer is madvr.

http://www.yetfiles.com/download/248/mpc-hc.DMP

Problem was solved by changing video renderer to evr.

comment:21 Changed 21 months ago by JellyFrog

  • Cc JellyFrog vaskie added

Does 331.93 help?

comment:22 Changed 21 months ago by underground78

@vaskie: You missed some part of step 2:

Here is the procedure to create a dump file manually:

  1. Reproduce the crash with MPC-HC, don't close the error message.
  2. If you're on a 32-bit operating system, open the task manager as usual or if you're on a 64-bit operating system, open the task manager from C:\Windows\SysWOW64\taskmgr.exe.
  3. Locate the mpc-hc.exe (or mpc-hc64.exe) process.
  4. Right click on it and press "Create Dump File" (or something similar).
  5. Upload the created dump file for us.


Also before uploading the dump, don't forget to compress it.

comment:23 Changed 21 months ago by vaskie

http://www.yetfiles.com/download/250/mpc-hc.zip

this is a dump file using the correct compressed and syswow64 way for drivers 331.93 using madvr. I get the same results as before. EVR is the only thing that is working for me atm.

comment:24 follow-up: Changed 21 months ago by JellyFrog

0 byte file?

comment:25 in reply to: ↑ 24 Changed 20 months ago by JellyFrog

nVidia's tech support: "I can confirm that the MPC issue is a known problem we are currently investigating."

comment:26 Changed 20 months ago by kasper93

  • Cc kasper93 added
  • Resolution set to fixed
  • Status changed from new to closed

Apparently they fixed this bug in latest release GeForce 332.21 WHQL Drivers

[Surround][Media Player Classic]: The media player freezes when attempting to open video files with Surround enabled. [1406828]

I'm closing the ticket, If you have any more problems fell free to reply.

Note: See TracTickets for help on using tickets.