Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#3028 closed Bug (fixed)

Bug with shuffle option

Reported by: cmolotov Owned by: Underground78
Priority: normal Milestone: 1.7.9
Component: General Version: 1.6.6.6957
Severity: normal Keywords:
Cc: Underground78, patrick+hogg Evaluation:

Description

MPC-HC often report errors, like unavalaible or unknown. This behaviour is only with saved as shuffle playlist. Playlist works corretly, but when I'm watching films not fullscreen and I double-click on this playlist Begin regular procedure - reporting error connect to Your help-site. Then one player close and another plays.I'm sure a reason is using a playlists saved with SHUFFLE option, and this is why I Begin a new track. I send two .dmp files

Attachments (2)

mpc-hc64.exe.1.6.6.6957.dmp (64.3 KB) - added by cmolotov 7 years ago.
sceen1a.jpg (120.0 KB) - added by cmolotov 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by cmolotov

Attachment: mpc-hc64.exe.1.6.6.6957.dmp added

comment:1 Changed 7 years ago by thevbm

Cc: Underground78 added

stack trace

 	mpc-hc64.exe!CPlayerPlaylistBar::SetFirstSelected() Line 699	C++
 	mpc-hc64.exe!CMainFrame::OpenCurPlaylistItem(rtStart=138861056) Line 14435	C++
 	mpc-hc64.exe!CMainFrame::OnCopyData(pWnd=0x00000000774e6bad, pCDS=0x0000000000000002) Line 4276	C++
 	mpc-hc64.exe!CWnd::OnWndMsg(message=74, wParam=0, lParam=2620592, pResult=0x000000000027f910) Line 2310	C++
 	mpc-hc64.exe!CWnd::WindowProc(message=74, wParam=0, lParam=2620592) Line 2087	C++
 	mpc-hc64.exe!CMainFrame::WindowProc(message=1076065648, wParam=2620592, lParam=5371043028) Line 15862	C++
 	mpc-hc64.exe!AfxCallWndProc(pWnd=0x0000000002635010, hWnd=0x0000000140237570, nMsg=74, wParam=0, lParam=2620592) Line 257	C++
 	mpc-hc64.exe!AfxWndProc(hWnd=0x00000000000b03fc, nMsg=74, wParam=0, lParam=2620592) Line 419	C++
 	user32.dll!UserCallWinProcCheckWow()	Unknown
 	user32.dll!DispatchClientMessage()	Unknown
 	user32.dll!__fnCOPYDATA()	Unknown
 	ntdll.dll!KiUserCallbackDispatcherContinue()	Unknown
 	user32.dll!ZwUserGetMessage()	Unknown
 	user32.dll!GetMessageW()	Unknown
>	mpc-hc64.exe!AfxInternalPumpMessage() Line 153	C++
 	mpc-hc64.exe!CWinThread::Run() Line 634	C++
 	mpc-hc64.exe!AfxWinMain(hInstance=0x000000013f950000, hPrevInstance=0x0000000000000000, lpCmdLine=0x0000000000392a5c, nCmdShow=1) Line 47	C++
 	mpc-hc64.exe!__tmainCRTStartup() Line 275	C
 	kernel32.dll!BaseThreadInitThunk()	Unknown
 	ntdll.dll!RtlUserThreadStart()	Unknown

Last edited 7 years ago by thevbm (previous) (diff)

comment:2 Changed 7 years ago by cmolotov

Thanks, but tell me what I can do it with this?

comment:3 in reply to:  2 Changed 7 years ago by thevbm

Replying to cmolotov:

Thanks, but tell me what I can do it with this?

Sorry for not making myself clear, this was intended for underground78 so he can take a look at it and possibly have an idea why the crash happen. He'll provide us with further instructions.

Last edited 7 years ago by thevbm (previous) (diff)

comment:4 Changed 7 years ago by cmolotov

Well, we will wait here, thanks a lot...

comment:5 Changed 7 years ago by Underground78

Ok I don't really understand what happens. I would need a step-by-step description of what you do to reproduce this error. If you think you can't do it in English do it in French and I will translate.

Changed 7 years ago by cmolotov

Attachment: sceen1a.jpg added

comment:6 Changed 7 years ago by cmolotov

OK,step by step; You can reset MPC or not, no matter, but you should use one player for each file option. I,m sure reason of these behaviours is the one - using saved playlist, but the playlist must be set as shuffle playlist. When you have this playlist on desktop, open a film and then run this playlist using doubleclick; nothing? Run playlist and run it again; there's no problem when you randomize playlist. I hope you understand this time,see yo

comment:7 Changed 7 years ago by Underground78

Summary: Newest stable MPC-HC strange errorsBug with shuffle option

comment:8 Changed 6 years ago by Underground78

Cc: patrick+hogg added
Owner: set to Underground78
Status: newaccepted

Ref: #4656.

Steps to reproduce:

  1. Ensure that MPC is shuffling the playlist
  2. Open a playlist
  3. Play a song
  4. Hit next
  5. Clear the playlist (while song is playing)
  6. Open the same playlist
  7. Play a song
  8. Hit next
  9. A crash ensues.

comment:9 Changed 5 years ago by Underground78 <underground78@…

Resolution: fixed
Status: acceptedclosed

In 29bf11:

Playlist: Fix and improve shuffle mode:

  • If the playlist was cleared and then the items readded, pressing next would cause a crash (fixes #3028).
  • The first item to play was always the first one in the playlist (fixes #3128).
  • Playback would stop after playing the last item of the playlist even if not all tracks had been played (fixes #80).
  • Going to the previous file used the playlist order instead of the shuffled order (fixes #4442).
  • No tracks will be repeated unless all tracks have been played at least once (fixes #4616).

comment:10 Changed 5 years ago by Underground78

Milestone: next release

Will be in the nightly builds as of revision 1.7.8.211.

comment:11 Changed 5 years ago by thevbm

Milestone: next release1.7.9

Milestone renamed

Note: See TracTickets for help on using tickets.