Opened 5 years ago

Closed 22 months ago

#277 closed Bug (wontfix)

MPC Video Decoder causes BSOD on XP with DXVA and Intel GMA500

Reported by: snowbird50 Owned by:
Priority: normal Milestone:
Component: General Version: 1.3.1249
Severity: blocker Keywords: _dxva_ unconfirmed
Cc: Evaluation:

Description

I recently bought an Asus 1201HA with Z520 CPU and Intel GMA 500, and XP SP3 installed, which accelerates (DXVA) MP4 AVC video perfectly using PowerDVD9.

When I installed MPC-HC 1249, and opened any MP4 AVC file I got a BSOD! I have installed both the latest beta 1650 and the earlier 908 and 604 with the same result.

By simply deselecting the internal H264/AVC (DXVA) Transform filter, (which disables DXVA in the internal MPC-Video decoder) the problem goes away. Deselecting the internal H264/AVC (ffmpeg) Transform filter as well (which totally disables the internal MPC-Video decoder) and making the CoreAVC video decoder the highest merit also makes the problem go away, however making the external Gabest MPC-video Decoder the higest merit, the BSOD returns.

Using Zoom with CoreAVC plays the video correctly. Using Zoom with the Gabest MPC-Video Decoder also creates a BSOD.

While others have reported that MPC-HC works correctly with the GMA 500 under W7, I believe this demonstrates a bug in the DXVA support portion of the MPC-Video Decoder when used with the GMA500 on XP.

Before reporting this as an MPC-HC bug and providing the requisite information, I want to verify that this is the correct place to report a "filter" bug. I am willing to work with you to provide what ever info is required to fix this. See bug 233 requesting GMA500 support for more info and attachments.

Thanks Casmir!

Change History (17)

comment:1 Changed 5 years ago by snowbird50

This should be classified as MPC-HC Video Renderer not Audio, but I see no way to edit my submission to correct this.

comment:2 Changed 5 years ago by xhmikosr

Please, try the latest version available and report back.

http://www.xvidvideo.ru/media-player-classic-home-cinema-x86-x64/

comment:3 Changed 5 years ago by snowbird50

Yes, tested 1650 already as well as earlier versions "I have installed both the latest beta 1650 and the earlier 908 and 604 with the same result."

BSOD info:

Stop:0X00008E (0XC00005, xxxxx,xxxxx, 0x000000)
igxpdd32.dll Address BFxxxxx base at BF01E0000, date stamp 4B17CBC6

where xxxxx varies with MPC-HC release.

This implies Intel XP GMA500 driver problem, but since POWERDVD9 DXVA works
correctly with this driver, (DXVA1 H.264 Support Profile: BSP: (X) BSP_Intel: (X) MC: (X) MC_ATI: (X) MC_NV: (X)), I believe it indicates a problem with how MPC-Video Decoder is interfacing with the XP driver, or perhaps Cyberlink found a workaround to an XP driver bug?

Thanks for your fast response. I am available to work with you and provide any info you need to test and fix this. I've been working on this for 2 weeks now to get it pinpointed to this precise point and repeatable error, so I'm prepared to do whatever it takes to fix this!

comment:4 Changed 5 years ago by tetsuo55

  • Cc casimir666 added
  • Component changed from MPC_HC_AUDIO_RENDERER to MPC_HC_CODECS
  • Keywords unconfirmed added

comment:5 Changed 5 years ago by snowbird50

More information as I keep working on this:

The MPC Video decoder creates a BSOD, regardless of the player in which it is used..Zoom, WMP or MPC-HC.

I have now also tested the latest ffdshow DXVA decoder with MPC-HC and it is also causing a BSOD.

So, either there is a bug in the Intel GMA500 XP driver which Cyberlink has been able to circumvent in order to make DXVA work, or both the MPC VD and ffdshow DXVA VD are feeding incorrect information to this driver.

Since POWERDVD9 can make DXVA work correctly with XP, I see no reason why the MPC VD and ffdshow DXVA VD cannot do the same. At a minimum they should not create a BSOD! Clearly the MPC VD believes DXVA should work since it does not revert to DXVA OFF mode.

I have attempted to use the Cyberlink H264 decoder (PDVD9)as a workaround but Zoom reports "Class not Registered" for this filter, and I have been unable to get it to load. Any ideas on how to fix that would be appreciated.

comment:6 Changed 5 years ago by snowbird50

This will confirm that both the Cyberlink Video Decoder and the Arcsoft Video Decoder used as external filters with MPC-HC fully supports DXVA on the GMA500.

On my Asus 1201 z520 system however, the internal DXVA transform, or the external ffmpeg(DXVA) or MPC Video Decoder give a BSOD, which I believe confirms that there is a bug in the common code of these decoders as reported above.

comment:7 Changed 5 years ago by papibe

I'm also getting BSOD on my Dell Inspiron mini 1010 while trying to play H264 videos.

MPCHC 1.3.1249.0
XP SP3
Internal Intel GMA500
no external codecs installed.

comment:8 Changed 5 years ago by tal_aloni

I've been working with jhb50 from doom9 who uses GMA500 and Win XP and have the same BSOD described above, (we used ffdshow for our tests, but it's the same code)

I published here the details we were able to collect:

http://software.intel.com/en-us/forums/showthread.php?t=72369

comment:9 Changed 5 years ago by tetsuo55

  • Component changed from MPC_HC_CODECS to New

comment:10 Changed 5 years ago by tal_aloni

jhb50 pointed out that the reason why Cyberlink and Arcsoft DXVA 1.0 decoders behave differenly might be because they are initializing the DXVA decoder for encrypted bitstream, while we do not.

the Intel guy was able to recreate this issue, I strongly believe it's not MPC-HC related, hopefully it will be solved soon.

comment:11 Changed 5 years ago by papibe

Any news about this?

comment:12 Changed 4 years ago by namaiki

  • Keywords _dxva added; unconfirmed removed

comment:13 Changed 4 years ago by namaiki

  • Keywords dxva added; _dxva removed

comment:14 Changed 4 years ago by namaiki

  • Keywords _dxva_ unconfirmed added; dxva removed

comment:15 Changed 4 years ago by namaiki

Also see #233

Any difference with the latest MPC-HC?
(MPC-HC v1.5.0.2827 and MPC-HC v1.4.2824.0_32 bits)

https://sourceforge.net/projects/mpc-hc/files/MPC%20HomeCinema%20-%20Win32/

comment:16 Changed 3 years ago by thevbm

  • Cc casimir666 removed

Please try with more recent release of MPC-HC.

Reference to #1329 and #1847 being closed as dupe of this one.

comment:17 Changed 22 months ago by JellyFrog

  • Resolution set to wontfix
  • Status changed from new to closed

Sorry, DXVA on XP has been dropped.
Upgrade to Win 7/8

Note: See TracTickets for help on using tickets.