Opened 4 years ago

Closed 20 months ago

Last modified 17 months ago

#2731 closed Bug (fixed)

MPC-HC repeat forever doesn't work when Foobar is using wasapi

Reported by: stormfriend Owned by:
Priority: normal Milestone: 1.7.10
Component: General Version: 1.6.4.6052
Severity: minor Keywords:
Cc: Evaluation:

Description

Repeat forever doesn't work when MPC is set to use the default audio device and Foobar is using the same device with Wasapi. It plays the video once and then stops on the last frame.

Specifying the audio device in MPC (but not Direct Sound) allows it to work normally. Specifying the Direct Sound version of the device causes the following error (when the error is closed the movie plays and repeats as expected):

MPC MP4/MOV Source::dicas Audio Handler - MPEG-4 Audio
MPC Audio Decoder::Out
Audio Switcher::Out

Media Type 0:


Audio: PCM 48000Hz stereo 1536kbps

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: MEDIASUBTYPE_PCM {00000001-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 4
cbFormat: 18

WAVEFORMATEX:
wFormatTag: 0x0001
nChannels: 2
nSamplesPerSec: 48000
nAvgBytesPerSec: 192000
nBlockAlign: 4
wBitsPerSample: 16
cbSize: 0 (extra bytes)

pbFormat:
0000: 01 00 02 00 80 bb 00 00 00 ee 02 00 04 00 10 00 ....€»...î......
0010: 00 00

I'm using the M2Tech HiFace driver on Win 7 x64 in case it matters. I had the same problem with earlier versions of MPC-HC as well.

Change History (2)

comment:1 Changed 20 months ago by alexmarsev

  • Milestone changed from next release placeholder to next release
  • Resolution set to fixed
  • Status changed from new to closed

Shouldn't be an issue anymore.

comment:2 Changed 17 months ago by thevbm

  • Milestone changed from next release to 1.7.10

Milestone renamed

Note: See TracTickets for help on using tickets.