Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2384 closed Bug (invalid)

mplayer crash on capturing stream

Reported by: hari_g Owned by:
Priority: normal Milestone:
Component: General Version: 1.6.2.4902
Severity: major Keywords:
Cc: Evaluation:

Description

mplayer-hc - 1.6.2.4092
Windows vista 32-bit all updates installed.
xvidcore.dll - latest

Once I start capturing a stream from a webcam to disk using Xvid MPEG-4 codec mplayer segfaults. Xvid codec is the latest one available.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 3156.0x6b8]
0x07ed7d15 in xvidcore!xvid_encore () from C:\Windows\system32\xvidcore.dll
(gdb) bt
#0 0x07ed7d15 in xvidcore!xvid_encore () from C:\Windows\system32\xvidcore.dll
#1 0xfffff100 in ?? ()
#2 0x000001e0 in ?? ()
#3 0x00000280 in ?? ()
#4 0x00000040 in ?? ()
#5 0x00000080 in ?? ()
#6 0x00000780 in ?? ()
#7 0x00000002 in ?? ()
#8 0x0000027e in ?? ()
#9 0x000001e0 in ?? ()
#10 0x07e816ca in ?? () from C:\Windows\system32\xvidcore.dll
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Minidump attached

Attachments (1)

mplayer-1.6.2.4902-dmp.7z (12.0 KB) - added by hari_g 3 years ago.
Mini dump file

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by hari_g

Mini dump file

comment:1 Changed 3 years ago by xhmikosr

  • Milestone next release placeholder deleted
  • Resolution set to invalid
  • Status changed from new to closed

Why did you rename the exe? And if the problem is in the xvidcore why do you think it's related to mpc-hc and open a (useless) ticket?

comment:2 Changed 3 years ago by hari_g

Why did you rename the exe?

Well, only for convenience. Keeping the original name didn't help to avoid the crash.

And if the problem is in the xvidcore why do you think it's related to mpc-hc and open a (useless) ticket?

In this case, if xvidcore foobared, that does not mean mplayer should crash because of that. My only intention was that you guys could do something to avoid such a crash. Only after attaching gdb, I came to see the stack mentioning xvidcore. As an end user it was mpc-hc that crashed for me.

comment:3 Changed 3 years ago by underground78

We have no control over what happens in xvidcore so if a segfault happens there I doubt there is something we can do to prevent MPC-HC from crashing.

However to be sure that MPC-HC isn't the cause of the problem you might want to try another codec.

Note: See TracTickets for help on using tickets.