Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2121 closed Bug (fixed)

Bit stream with LTR not supporting in ATI cards such as HD 6950, HD5770

Reported by: smilegg Owned by:
Priority: normal Milestone: 1.6.1
Component: General Version: 1.6.0.4014
Severity: critical Keywords: DXVA LTR mosaic
Cc: aleksoid Evaluation:

Description

Hi all,
When we use MPC to play AVC 720P MP4 file with there is LTR in bit stream on ATI HD cards such as HD 6950 and HD 5770, we found there is mosaic in output.
When we use MPC on NVIDIA cards, there is no mosaic.
Maybe there is error in our code for processing reference frame list especially for LTR in DXVA part, or there is something wrong on driver of ATI for DXVA with LTR?

Change History (16)

comment:1 Changed 4 years ago by smilegg

The OS we tested is 64bit Win7, DXVA used in MPC is DXVA 2.0.

comment:2 Changed 4 years ago by smilegg

on NVIDIA card GTX 560, we also find there is mosaic in output too.

comment:3 Changed 4 years ago by aleksoid

What is "LTR" ???

comment:4 Changed 4 years ago by nevcairiel

Long-term Reference, i guess.

comment:5 Changed 4 years ago by smilegg

yes, LTR is Long-term Reference Frame. I only have and test on HD 6950, HD5770 cards, i guess the problem is exist in more ATI cards which supports DXVA.

comment:6 Changed 4 years ago by aleksoid

Need a sample file.

comment:7 Changed 4 years ago by smilegg

how to update sample file? The size of attached file is only 256 KB. The MP4 file is multi MB.

comment:8 Changed 4 years ago by smilegg

if you can give one mail address, i will send sample MP4 file to you. thx.

comment:9 Changed 4 years ago by thevbm

use mediafire.com or maybe even dropbox

comment:10 Changed 4 years ago by smilegg

http://www.mediafire.com/?2jxtmi5iywck5rs . MP4 file is attached here. You can download and try if there is mosaic on ATI or NVIDIA cards which supports DXVA 2.0. on Vista or Win7. thx.

comment:11 Changed 4 years ago by nevcairiel

I can confirm the internal decoder produces artifacts in that file, even on my NVIDIA.
LAV is fine.

comment:12 Changed 4 years ago by aleksoid

Test - http://aleksoid.tosei.ru/Test/mpc-hc.DXVA_LTR.7z
And - give me more sample, it it's test build don't work.

comment:13 Changed 4 years ago by aleksoid

  • Resolution set to fixed
  • Status changed from new to closed

Fix at rev. 4230;

comment:14 Changed 4 years ago by smilegg

Sorry, on NVIDIA card, test build can work well. But on ATI card, mosaic can be also found in test build.

comment:15 Changed 4 years ago by underground78

  • Cc aleksoid added

comment:16 Changed 4 years ago by underground78

  • Component changed from New to Solved
  • Milestone changed from next release placeholder to next release

See #2132.

Note: See TracTickets for help on using tickets.