Opened 5 years ago

Closed 5 years ago

#1557 closed Feature Request (duplicate)

Option to have hand-cursor enabled (old cursor behavior)

Reported by: voodoobs Owned by:
Priority: normal Milestone:
Component: General Version: 1.5.2.3456
Severity: minor Keywords: hand cursor behavior
Cc: underground78 Evaluation:

Description

Recent change to 1.5.2.3456,

"The hand cursor is not used anymore for the video frame unless the mouse pointer hovers a button in a DVD menu."

no longer allows the player to be moved when Caption&Menu is disabled using the video frame. In order to move the frame, Caption&Menu needs to be enabled or using the Status/Statistics/Information areas to move (which means one needs to be enabled).

If this change is to be permanent, it would be nice to have the option to go back to the older cursor behavior to enable moving MPC using the video frame.

Change History (5)

comment:1 Changed 5 years ago by underground78

  • Cc underground78 added; 1.5.2.3456 removed
  • Component changed from New to Need Info
  • Version changed from SVN, specify to 1.5.2.3456

This is not related to the fact the cursor has been changed I think. Have you tried doing that: "In the the options of MPC go to "Player > Keys", look for the "Play/Pause" command and in the column "Mouse" change the default "Left Down" to "Left Up"."

comment:2 Changed 5 years ago by voodoobs

oh - thanks.
that does allow me to move the window using the video frame for the version 1.5.2.3456.

it does seem that the mouse-cursor change did affect it, as i was able to move the window as long as the mouse-cursor was the "hand" icon in the older versions.

thanks for the "fix", though.

comment:3 Changed 5 years ago by underground78

The default button for "Play/Pause" was probably changed too. Can you still pause the video when you use "Left Up" ?

comment:4 Changed 5 years ago by voodoobs

i can pause/unpause the video by clicking when it's in fullscreen mode.
when it's in a window, clicking the video-frame results in nothing.

this was the behavior before 1.5.2.3456 and, as far as i can remember, has been the
default for MPC since way back.

with 1.5.2.3456 and the mouse behavior change, the default no longer allows you to drag the video-frame to move the window but now also mimics fullscreen behavior in pausing/unpausing if left to "Left Down."

comment:5 Changed 5 years ago by underground78

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #1427 so I will close it and put you in CC of #1427.

Note: See TracTickets for help on using tickets.