Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#1478 closed Bug (fixed)

Frame step forward doesn't change frame number in "Go To..." window

Reported by: lord-d Owned by: underground78
Priority: normal Milestone: 1.7.1
Component: General Version: 1.5.0.2827
Severity: trivial Keywords:
Cc: underground78 Evaluation: need info

Description

  1. Open any video
  2. Note the frame number in "Go To..." window
  3. Step forward for several frames
  4. Frame number changes only after first step forward.

Step back normally changes the frame number.

Filters:
Default DirectSound Device
Haali's Video Renderer
ffdshow Video Decoder
ffdshow Audio Decoder
Haali Media Splitter

OS: Windows 7 x64

Attachments (1)

02.04.12.png (153.4 KB) - added by lord-d 4 years ago.
MPC-HC 1.6.1.4193 x64

Download all attachments as: .zip

Change History (14)

comment:1 follow-up: Changed 5 years ago by underground78

  • Component changed from New to Need Info

I think I can't reproduce but I'm not sure to have correctly understood your explanation. Here what I've done:

  1. Pause the video
  2. Open "Go to" dialog, note the frame number and then close the dialog
  3. Step forward a few times
  4. Open again "Go to".

After step 4, the frame number seems to have changed correctly.

comment:2 Changed 5 years ago by underground78

  • Cc underground78 added

comment:3 in reply to: ↑ 1 Changed 5 years ago by lord-d

Replying to underground78:
Here's the video: http://www.mediafire.com/?gb5uz86p5pevpas
It seems that a bug is better is reproduced with Haali Video Renderer, but sometimes is reproduced with EVR (some frames are skipped).

comment:4 follow-up: Changed 4 years ago by underground78

Are you still experiencing this issue with latest revisions?

comment:5 in reply to: ↑ 4 Changed 4 years ago by lord-d

Replying to underground78:
Yes. I'm currently using MPC-HC 1.6.1.4193 x64.

comment:6 follow-up: Changed 4 years ago by underground78

Are you using Haali Video Renderer because I still can't reproduce?

Changed 4 years ago by lord-d

MPC-HC 1.6.1.4193 x64

comment:7 in reply to: ↑ 6 Changed 4 years ago by lord-d

Replying to underground78:
Yes. I attached a screenshot.

comment:8 follow-up: Changed 4 years ago by underground78

It must be a bug in HVR then because I really can't reproduce that. I'm not quite sure there is something we can do. :/

comment:9 in reply to: ↑ 8 Changed 4 years ago by lord-d

First, how HVR can affect on the frame number deep in the MPC? Secondly, in one of the previous comments I wrote that this bug can be reproduced as well with EVR. In any case, it is not important bug and you can arrive with it as you wish :)

comment:10 Changed 3 years ago by underground78

I have tested again and it seems that it's just HVR that doesn't report the right position in the file after stepping forward.

The slightly inconsistency that can be noticed with the other renderers are just rounding issues when computing the frame number. I will commit a small change to improve the precision.

comment:11 Changed 3 years ago by Underground78 <underground78@…

  • Owner set to Underground78 <underground78@…>
  • Resolution set to fixed
  • Status changed from evaluated to closed

In 3394fdfe4bc2a1d73c5f84e85ac85c26e21d3468:

Go To dialog: Slightly improve the precision of the frame number.

The frame number was sometimes off by 1.

This commit fixes #1478.

comment:12 Changed 3 years ago by xhmikosr

  • Milestone set to next release

comment:13 Changed 3 years ago by xhmikosr

  • Owner changed from Underground78 <underground78@… to underground78
Note: See TracTickets for help on using tickets.