Opened 5 years ago

Last modified 5 years ago

#1467 reopened Bug

Snapshot jumps ahead instead of saving current frame

Reported by: quinncollard Owned by:
Priority: normal Milestone:
Component: General Version: nightly, specify
Severity: major Keywords: snapshot save image screencapture
Cc: aleksoid, stevebunsrm, v0lt Evaluation:

Description

When I do "save image" to do a screencapture, the video jumps ahead by several frames. This was happening occasionally on earlier versions of MPC but is happening very frequently now. Thanks in advance for any help.

Change History (16)

comment:1 follow-up: Changed 5 years ago by underground78

  • Component changed from New to Need Info

Is the playback paused when you do the screeshot ?

comment:2 in reply to: ↑ 1 Changed 5 years ago by quinncollard

Replying to underground78:

Is the playback paused when you do the screeshot ?

Yes.

comment:3 Changed 5 years ago by namaiki

Which video renderer, video decoder and splitter are being used? (You can refer to the Play-> Filters menu)

comment:4 follow-up: Changed 5 years ago by quinncollard

Sorry for not replying to this in awhile, I have been in and out of the hospital. Here's what they are:
Video renderer: Xvid MPEG-4 Video Decoder
Video decoder: AAC decoder
I don't see where it says anything about a splitter. Hope those two are the right things--the menu is a little confusing to me.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 5 years ago by aleksoid

Replying to quinncollard:

Sorry for not replying to this in awhile, I have been in and out of the hospital. Here's what they are:
Video renderer: Xvid MPEG-4 Video Decoder
Video decoder: AAC decoder
I don't see where it says anything about a splitter. Hope those two are the right things--the menu is a little confusing to me.

What Video Render use ???

comment:7 in reply to: ↑ 6 ; follow-up: Changed 5 years ago by quinncollard

Replying to aleksoid:

Try http://aleksoid.tosei.ru/Test/mpc-hc.exe_image_save.7z

Winzip is giving me an error when I try to open that.

comment:8 in reply to: ↑ 5 Changed 5 years ago by quinncollard

Replying to aleksoid:

What Video Render use ???

Like I said, when I click on Video Renderer the thing that I think is it says "Xvid MPEG-4 Video Decoder." There is a thing that says "Quality" and then in "Pin Info" it says "[IN] VMR Input0" and then:

  • Connected to:

CLSID: {64697678-0000-0010-8000-00AA00389B71}
Filter: Xvid MPEG-4 Video Decoder
Pin: XForm Out

  • Connection media type:

Video: YUY2 768x540 (4:3)

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
subtype: MEDIASUBTYPE_YUY2 {32595559-0000-0010-8000-00AA00389B71}
formattype: FORMAT_VideoInfo2 {F72A76A0-EB0A-11D0-ACE4-0000C0CC16BA}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 829440
cbFormat: 1152

comment:9 in reply to: ↑ 7 ; follow-up: Changed 5 years ago by aleksoid

Replying to quinncollard:

Replying to aleksoid:

Try http://aleksoid.tosei.ru/Test/mpc-hc.exe_image_save.7z

Winzip is giving me an error when I try to open that.

It's a 7z arc, http://www.7-zip.org/

comment:10 in reply to: ↑ 9 Changed 5 years ago by quinncollard

Replying to aleksoid:

Replying to quinncollard:

Replying to aleksoid:

Try http://aleksoid.tosei.ru/Test/mpc-hc.exe_image_save.7z

That's working so far--thank you!

comment:11 Changed 5 years ago by aleksoid

  • Resolution set to fixed
  • Status changed from new to closed

comment:12 Changed 5 years ago by underground78

  • Cc aleksoid added
  • Component changed from Need Info to New
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.5.0.2827 to SVN, specify

Replying to quinncollard:

I already had this as a ticket but I thought it was fixed and so it was closed. I tried to reopen it but it's telling me I don't have permission to do that. Here's the problem:

When I do "save image" to do a screencapture, the video jumps ahead by several frames. This was happening occasionally on earlier versions of MPC but is happening very frequently now. I have the video paused while I'm trying to do it.

I downloaded the version of MPC someone suggested and it stopped doing it with the file I was working on but now I am trying with a different file and it's started happening with that one. I am using MPC Video Decoder on this one. Here is the ticket I submitted before: https://sourceforge.net/apps/trac/mpc-hc/ticket/1467

comment:13 Changed 5 years ago by underground78

  • Cc stevebunsr added

From #1638:

Replying to stevebunsr:

My computer is:
Windows xp
MPC version 3592

Happens with MPC decoders or ffdshow decoder. Happens in VMR-7 windowed or VMR-9 windowed.

The problem is that MPC will not save the frame you are on. For example this video:
http://vimeo.com/23798312

You can download from that website using browser tool or download directly from:
http://www.mediafire.com/?dvwckca205quni7

Go to 9 seconds mark in video. While paused, use frame step key to get to the frame exactly when the frogs feet first leave the ground.

I've uploaded snapshot where the feet are pointed straight down. The frame you should try to save is exactly 1 frame forward from what's seen in snapshot.

Even though you are paused on frame where feet are first off ground and pointing backwards, the frame you are paused on will not get saved. MPC will move back and save the frame before it.

comment:14 Changed 5 years ago by janwillem32

The issue here is that the image saving functions don't save a renderered image, but a half-finished frame from the mixer in the case of VMR-9 r., EVR CP and EVR Sync.
The mixer has a default queue of 4 frames, and when framestepping, it just hands out a frame in memory, without changing the one marked as in use.
This proplem is in origin the same as Ticket #46.

comment:15 Changed 5 years ago by stevebunsr

So will this issue be fixed?

Is it a matter of correcting the frame marking?

comment:16 Changed 5 years ago by thevbm

  • Cc stevebunsrm v0lt added; stevebunsr removed

What's the status on this one ?

Note: See TracTickets for help on using tickets.