Opened 7 years ago

Closed 3 years ago

Last modified 3 years ago

#11 closed Feature Request (fixed)

[RAW] Add playback AC3 stream embedded in TrueHD

Reported by: rusneuromancer Owned by:
Priority: normal Milestone:
Component: Internal Filters Version: nightly, specify
Severity: minor Keywords:
Cc: Evaluation:

Description

Windows version: Windows 7 6.1.7600 x64 with all updates
DirectX version: DirectX August 2009
.NET version: Microsoft .NET Framework 3.5 Service Pack 1 with all
updates
Videocard: nVidia GeForce 9600 GT
Videocard driver version: 190.38 WHQL
VC2005 version: ATL Update kb973923 8.0.50727.4053
VC2008 version: Redistributable 9.0.30729.17 and ATL Update kb973924
9.0.30729.4148
MPC-HC version: 1.3.1276.0 x64
Last working build: no one
Registry cleaned: yes
Ini file cleaned: yes
Internal audio filter: bug confirmed
External audio filter: bug confirmed (ffdshow audio)
Link to splitters/filters screenshot:
http://img27.imageshack.us/img27/3294/filters1.png
http://img180.imageshack.us/img180/8026/filters2.png
Media info: http://freetexthost.com/b1wltruxcs
Internal subtitle renderer: on
Subtitle animation: on
Subtitle buffering: 0
EVR buffers: 4
Shaders enabled: no
Resizer used: Bicubic A=-1.00 (PS 2.0)
Link to sample: http://sharebee.com/2fc570dc

Change History (8)

comment:1 Changed 7 years ago by tetsuo55

  • Component changed from MPC_HC_AUDIO_RENDERER to MPC_HC_SPLITTER
  • Summary changed from Playing of separate TrueHD (maybe AC3 too) is very fast to [RAW] Playing of separate TrueHD (maybe AC3 too) is very fast

comment:2 Changed 6 years ago by tetsuo55

  • Component changed from MPC_HC_SPLITTER to New

comment:3 Changed 6 years ago by xhmikosr

Using the internal filters, I got it to crash.

FOLLOWUP_IP:
mpc_hc!CAMThread::CallWorker+42 [h:\progs\compiling\mpc-hc_dev\src\filters\baseclasses\wxutil.cpp @ 178]
0133f882 8b7610 mov esi,dword ptr [esi+10h]

FAULTING_SOURCE_CODE:

174: wait for the completion to be signalled
175: m_EventComplete.Wait();
176:
177:
done - this is the thread's return value

178: return m_dwReturnVal;

179: }
180:
181: Wait for a request from the client
182: DWORD
183: CAMThread::GetRequest()

comment:4 Changed 5 years ago by xhmikosr

  • Cc aleksoid v0lt added

comment:5 Changed 5 years ago by v0lt

  • Severity changed from critical to minor
  • Summary changed from [RAW] Playing of separate TrueHD (maybe AC3 too) is very fast to [RAW] Add playback AC3 stream embedded in TrueHD
  • Type changed from Bug to Feature Request

[RAW] Playing of separate TrueHD (maybe AC3 too) is very fast

I do not see a "very fast" playback. There is no playback.
Built-in decoder does not support the TrueHD.

comment:6 Changed 5 years ago by aleksoid

What player/splitter/decoder can play this file ??? i try LAV Splitter - it's can't too playback.

comment:7 Changed 3 years ago by JellyFrog

  • Resolution set to fixed
  • Status changed from new to closed

Works for me with latest nightly.
http://www.mediafire.com/file/bbq8x233d771f3b/hd_dolby_bit_harvest_lossless.m2ts

Audio
ID                             : 4352 (0x1100)
Menu ID                        : 1 (0x1)
Format                         : TrueHD / AC-3
Mode extension                 : CM (complete main)
Format settings, Endianness    : Big
Muxing mode                    : Stream extension
Codec ID                       : 131
Duration                       : 11s 12ms
Bit rate mode                  : Variable / Constant
Bit rate                       : 640 Kbps
Maximum bit rate               : 6 423 Kbps
Channel(s)                     : 8 channels / 6 channels
Channel positions              : Front: L C R, Side: L R, Back: L R, LFE / Front: L C R, Side: L R, LFE
Sampling rate                  : 48.0 KHz
Bit depth                      : 16 bits
Stream size                    : 860 KiB (2%)

comment:8 Changed 3 years ago by xhmikosr

  • Cc aleksoid v0lt removed
  • Component changed from General to Internal Filters
Note: See TracTickets for help on using tickets.